summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJames McCoy <jamessan@debian.org>2018-04-07 11:00:42 -0400
committerJames McCoy <jamessan@debian.org>2018-04-07 11:03:18 -0400
commit75845ec30fe90a901138b1a253b9f4d4411a799b (patch)
tree52a4f8ab7ad6c88e0406cd08ac1315ae9d330857 /debian
parenta93d192468bba7499f93dc03f56ee0191071eb8b (diff)
rules: Ensure Perl binding shared libs are writable before deleting RPATH
Since Rules-Requires-Root is now set to "no", the install target is being run as a non-root user. This caused "chrpath --delete" to fail since the Perl shared libs are (for some reason) being created with 0555 permissions. Signed-off-by: James McCoy <jamessan@debian.org>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 1a7fb36..7b2f2da 100755
--- a/debian/rules
+++ b/debian/rules
@@ -353,7 +353,7 @@ endif
# There are some non-ELF files in /usr/bin, so ignore errors
chrpath --keepgoing --delete "$(CURDIR)/debian/tmp/usr/bin/"* || true
- find "$(CURDIR)/debian/tmp$(libdir)" -type f -name '*.so' -exec chrpath --delete '{}' +
+ find "$(CURDIR)/debian/tmp$(libdir)" -type f -name '*.so' -exec chmod u+w '{}' + -exec chrpath --delete '{}' +
dh_install -a
# Install files for 'subversion-tools' package.