summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index b260aa9..b226a5a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -46,6 +46,10 @@ $(foreach o, $(d_b_o), \
$(foreach o, $(filter NO_%,$(d_b_o)), $(eval DEB_OPT_$(subst NO_,WITH_,$o) :=))
$(if $(DEB_OPT_PARALLEL),$(eval MAKEFLAGS += -j$(DEB_OPT_PARALLEL)))
+ifndef DEB_OPT_TERSE
+ MAKE_B += LTFLAGS="--tag=CC" LTCXXFLAGS="--tag=CXX"
+endif
+
# How to fix "#!/usr/bin/env " lines: $(call fix_shebangs_in, /your/dir)
fix_shebangs_in = \
find $1 -type f | xargs -r egrep -m1 -c '^\#! ?/' | sed -n 's/:1//p' |\