summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/apr-abi2
-rw-r--r--debian/patches/build-fixes12
-rw-r--r--debian/patches/last-changed-date-charset8
-rw-r--r--debian/patches/python-builds16
-rw-r--r--debian/patches/repos-templates2
-rw-r--r--debian/patches/rpath4
-rw-r--r--debian/patches/ruby-no-strict-aliasing6
-rw-r--r--debian/patches/series4
-rw-r--r--debian/patches/ssh-no-controlmaster2
-rw-r--r--debian/patches/svnshell34
-rw-r--r--debian/patches/swig.m4-Do-not-include-ruby-include-subdir.patch24
-rw-r--r--debian/patches/use-python3-as-the-interpreter-now-for-tests-not-python.patch (renamed from debian/patches/use-python2-as-the-interpreter-now-for-tests-not-python.patch)8
12 files changed, 31 insertions, 91 deletions
diff --git a/debian/patches/apr-abi b/debian/patches/apr-abi
index 059e7c1..ec28190 100644
--- a/debian/patches/apr-abi
+++ b/debian/patches/apr-abi
@@ -16,7 +16,7 @@ be ABI-compatible again if and when we move to apr-2.x.
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
-index 4a3683c..232334d 100644
+index 07103e5..a2e343a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,7 +106,7 @@ if test `expr $apr_version : 2` -ne 0; then
diff --git a/debian/patches/build-fixes b/debian/patches/build-fixes
index f588703..066e303 100644
--- a/debian/patches/build-fixes
+++ b/debian/patches/build-fixes
@@ -12,10 +12,10 @@ Fix some build problems:
2 files changed, 6 insertions(+), 8 deletions(-)
diff --git a/Makefile.in b/Makefile.in
-index faf2a70..8c876b5 100644
+index 48a14bf..1390a69 100644
--- a/Makefile.in
+++ b/Makefile.in
-@@ -913,8 +913,7 @@ clean-swig-pl:
+@@ -918,8 +918,7 @@ clean-swig-pl:
fi
for d in $(SWIG_PL_DIR)/libsvn_swig_perl; \
do \
@@ -25,7 +25,7 @@ index faf2a70..8c876b5 100644
done
if [ -f "$(SWIG_PL_DIR)/native/Makefile" ]; then \
cd $(SWIG_PL_DIR)/native; $(MAKE) clean; \
-@@ -948,7 +947,7 @@ clean-swig-py:
+@@ -955,7 +954,7 @@ clean-swig-py:
fi
for d in $(SWIG_PY_DIR) $(SWIG_PY_DIR)/libsvn_swig_py; \
do \
@@ -34,7 +34,7 @@ index faf2a70..8c876b5 100644
done
find $(SWIG_PY_SRC_DIR) $(SWIG_PY_DIR) -name "*.pyc" -exec rm {} ';'
-@@ -980,8 +979,7 @@ clean-swig-rb:
+@@ -988,8 +987,7 @@ clean-swig-rb:
fi
for d in $(SWIG_RB_DIR) $(SWIG_RB_DIR)/libsvn_swig_ruby; \
do \
@@ -45,7 +45,7 @@ index faf2a70..8c876b5 100644
extraclean-swig-rb: clean-swig-rb
diff --git a/build.conf b/build.conf
-index 7631a61..29c2b60 100644
+index 1f0d2d8..2e3697a 100644
--- a/build.conf
+++ b/build.conf
@@ -189,7 +189,7 @@ path = subversion/svnserve
@@ -64,7 +64,7 @@ index 7631a61..29c2b60 100644
-libs = libsvn_wc libsvn_ra libsvn_delta libsvn_diff libsvn_subr apriconv apr
+libs = libsvn_wc libsvn_ra libsvn_delta libsvn_diff libsvn_subr aprutil apriconv apr
install = lib
- msvc-export = svn_client.h private/svn_client_mtcc.h private/svn_client_private.h
+ msvc-export = svn_client.h private/svn_client_mtcc.h private/svn_client_private.h private/svn_client_shelf.h private/svn_client_shelf2.h
@@ -323,7 +323,7 @@ msvc-export = private/svn_fs_util.h
description = Subversion General Repository Access Library
diff --git a/debian/patches/last-changed-date-charset b/debian/patches/last-changed-date-charset
index fd156c8..9f759f9 100644
--- a/debian/patches/last-changed-date-charset
+++ b/debian/patches/last-changed-date-charset
@@ -12,7 +12,7 @@ Not accepted upstream: http://svn.haxx.se/dev/archive-2006-04/0730.shtml
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/subversion/libsvn_subr/subst.c b/subversion/libsvn_subr/subst.c
-index c8c3018..b69f90a 100644
+index c8c3018..a1213cb 100644
--- a/subversion/libsvn_subr/subst.c
+++ b/subversion/libsvn_subr/subst.c
@@ -210,8 +210,12 @@ keyword_printf(const char *fmt,
@@ -21,10 +21,10 @@ index c8c3018..b69f90a 100644
if (date)
- svn_stringbuf_appendcstr(value,
- svn_time_to_human_cstring(date, pool));
-+ {
++ {
+ char *date_keyword;
-+ char *date_utf8 = svn_time_to_human_cstring (date, pool);
-+ svn_utf_cstring_from_utf8(&date_keyword, date_utf8, pool);
++ char *date_utf8 = svn_time_to_human_cstring(date, pool);
++ SVN_ERR(svn_utf_cstring_from_utf8(&date_keyword, date_utf8, pool));
+ svn_stringbuf_appendcstr(value, date_keyword);
+ }
break;
diff --git a/debian/patches/python-builds b/debian/patches/python-builds
index f55d7b7..30d79ab 100644
--- a/debian/patches/python-builds
+++ b/debian/patches/python-builds
@@ -14,7 +14,7 @@ Submitted upstream: http://svn.haxx.se/dev/archive-2008-05/0361.shtml
3 files changed, 13 insertions(+), 10 deletions(-)
diff --git a/Makefile.in b/Makefile.in
-index d6a173a..17632f0 100644
+index cee3c00..5eb6f45 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -148,6 +148,7 @@ BOOST_TEST_CPPFLAGS = @BOOST_CPPFLAGS@ -DBOOST_TEST_DYN_LINK -DBOOST_TEST_NO_MAI
@@ -22,11 +22,11 @@ index d6a173a..17632f0 100644
SWIG = @SWIG@
+PYTHON_INCLUDES = @PYTHON_INCLUDES@
- SWIG_PY_INCLUDES = @SWIG_PY_INCLUDES@ -I$(SWIG_SRC_DIR)/python/libsvn_swig_py
+ SWIG_PY_INCLUDES = @SWIG_PY_INCLUDES@ @SVN_PY3C_INCLUDES@ -I$(SWIG_SRC_DIR)/python/libsvn_swig_py
SWIG_PY_COMPILE = @SWIG_PY_COMPILE@
SWIG_PY_LINK = @SWIG_PY_LINK@
diff --git a/build.conf b/build.conf
-index 0c631bd..97218d7 100644
+index 53c0138..16bd7b9 100644
--- a/build.conf
+++ b/build.conf
@@ -498,7 +498,7 @@ external-project = svn_locale
@@ -109,10 +109,10 @@ index 0c631bd..97218d7 100644
lang = python
path = subversion/bindings/swig/python/libsvn_swig_py
diff --git a/build/ac-macros/swig.m4 b/build/ac-macros/swig.m4
-index 2963872..3c05797 100644
+index c707a8c..fea7f0d 100644
--- a/build/ac-macros/swig.m4
+++ b/build/ac-macros/swig.m4
-@@ -108,7 +108,8 @@ AC_DEFUN(SVN_FIND_SWIG,
+@@ -110,7 +110,8 @@ AC_DEFUN(SVN_FIND_SWIG,
AC_CACHE_CHECK([for Python includes], [ac_cv_python_includes],[
ac_cv_python_includes="`$PYTHON ${abs_srcdir}/build/get-py-info.py --includes`"
])
@@ -121,9 +121,9 @@ index 2963872..3c05797 100644
+ SWIG_PY_INCLUDES="\$(SWIG_INCLUDES) \$(PYTHON_INCLUDES)"
if test "$ac_cv_python_includes" = "none"; then
- AC_MSG_WARN([python bindings cannot be built without distutils module])
-@@ -266,6 +267,7 @@ int main()
- AC_MSG_RESULT([$SWIG_RB_TEST_VERBOSE])
+ SWIG_PY_ERRMSG="no distutils found"
+@@ -332,6 +333,7 @@ int main()
+ SWIG_RB_ERRMSG=""
fi
AC_SUBST(SWIG)
+ AC_SUBST(PYTHON_INCLUDES)
diff --git a/debian/patches/repos-templates b/debian/patches/repos-templates
index 2de5b12..e3fd6e5 100644
--- a/debian/patches/repos-templates
+++ b/debian/patches/repos-templates
@@ -12,7 +12,7 @@ hooks, not just use them in place.
1 file changed, 18 insertions(+), 10 deletions(-)
diff --git a/subversion/libsvn_repos/repos.c b/subversion/libsvn_repos/repos.c
-index f46b828..73f4022 100644
+index 2189de8..df87652 100644
--- a/subversion/libsvn_repos/repos.c
+++ b/subversion/libsvn_repos/repos.c
@@ -276,7 +276,7 @@ create_locks(svn_repos_t *repos, apr_pool_t *pool)
diff --git a/debian/patches/rpath b/debian/patches/rpath
index 0265d71..423c298 100644
--- a/debian/patches/rpath
+++ b/debian/patches/rpath
@@ -13,7 +13,7 @@ patch by David Kimdon <dwhedon@debian.org>. The basic theory is:
2 files changed, 4 insertions(+), 3 deletions(-)
diff --git a/build.conf b/build.conf
-index 29c2b60..0c631bd 100644
+index 2e3697a..53c0138 100644
--- a/build.conf
+++ b/build.conf
@@ -572,7 +572,7 @@ lang = python
@@ -35,7 +35,7 @@ index 29c2b60..0c631bd 100644
# need special build rule to include
compile-cmd = $(COMPILE_SWIG_RB)
diff --git a/build/generator/gen_base.py b/build/generator/gen_base.py
-index 458545c..a5054aa 100644
+index f3041f9..4d0e7f9 100644
--- a/build/generator/gen_base.py
+++ b/build/generator/gen_base.py
@@ -599,7 +599,7 @@ class TargetLinked(Target):
diff --git a/debian/patches/ruby-no-strict-aliasing b/debian/patches/ruby-no-strict-aliasing
index 85ff8a9..7e2d228 100644
--- a/debian/patches/ruby-no-strict-aliasing
+++ b/debian/patches/ruby-no-strict-aliasing
@@ -10,12 +10,12 @@ be real bugs with real consequences.
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.in b/Makefile.in
-index 8c876b5..d6a173a 100644
+index 1390a69..cee3c00 100644
--- a/Makefile.in
+++ b/Makefile.in
-@@ -154,7 +154,7 @@ SWIG_PY_LINK = @SWIG_PY_LINK@
- SWIG_PY_LIBS = @SWIG_PY_LIBS@
+@@ -156,7 +156,7 @@ SWIG_PY_ERRMSG = @SWIG_PY_ERRMSG@
SWIG_PL_INCLUDES = @SWIG_PL_INCLUDES@
+ SWIG_PL_ERRMSG = @SWIG_PL_ERRMSG@
SWIG_RB_INCLUDES = @SWIG_RB_INCLUDES@ -I$(SWIG_SRC_DIR)/ruby/libsvn_swig_ruby
-SWIG_RB_COMPILE = @SWIG_RB_COMPILE@
+SWIG_RB_COMPILE = @SWIG_RB_COMPILE@ -fno-strict-aliasing
diff --git a/debian/patches/series b/debian/patches/series
index f8ccabd..d1e1ffb 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -5,10 +5,8 @@ rpath
ruby-no-strict-aliasing
ruby-test-svnserve-race
ssh-no-controlmaster
-svnshell
apr-abi
python-builds
examples-compile-instructions
workaround_EINVAL_on_kfreebsd
-use-python2-as-the-interpreter-now-for-tests-not-python.patch
-swig.m4-Do-not-include-ruby-include-subdir.patch
+use-python3-as-the-interpreter-now-for-tests-not-python.patch
diff --git a/debian/patches/ssh-no-controlmaster b/debian/patches/ssh-no-controlmaster
index f1b9067..04ab32b 100644
--- a/debian/patches/ssh-no-controlmaster
+++ b/debian/patches/ssh-no-controlmaster
@@ -24,7 +24,7 @@ connection sharing, but only if a ControlMaster is already present.
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/subversion/libsvn_ra_svn/client.c b/subversion/libsvn_ra_svn/client.c
-index dd60dbe..afdd12a 100644
+index f484519..c6e3d77 100644
--- a/subversion/libsvn_ra_svn/client.c
+++ b/subversion/libsvn_ra_svn/client.c
@@ -399,7 +399,7 @@ static svn_error_t *find_tunnel_agent(const char *tunnel,
diff --git a/debian/patches/svnshell b/debian/patches/svnshell
deleted file mode 100644
index dc204f6..0000000
--- a/debian/patches/svnshell
+++ /dev/null
@@ -1,34 +0,0 @@
-From: James McCoy <jamessan@debian.org>
-Date: Wed, 1 Aug 2018 20:44:36 -0400
-Subject: svnshell
-
-Bug #234462: The error messages that svnshell spits out for unknown
-Bug #234462: The error messages that svnshell spits out for unknown
-commands are confusing. They should be replaced by a "Unknown command."
-error message. Upstream says we have no sense of humor. (:
-
-Patch from Roland Illig <roland.illig@gmx.de>.
----
- tools/examples/svnshell.py | 8 +-------
- 1 file changed, 1 insertion(+), 7 deletions(-)
-
-diff --git a/tools/examples/svnshell.py b/tools/examples/svnshell.py
-index 9c67af4..b05e7ef 100755
---- a/tools/examples/svnshell.py
-+++ b/tools/examples/svnshell.py
-@@ -56,14 +56,8 @@ class SVNShell(Cmd):
- def postcmd(self, stop, line):
- self._setup_prompt()
-
-- _errors = ["Huh?",
-- "Whatchoo talkin' 'bout, Willis?",
-- "Say what?",
-- "Nope. Not gonna do it.",
-- "Ehh...I don't think so, chief."]
--
- def default(self, line):
-- print(self._errors[randint(0, len(self._errors) - 1)])
-+ print "Unknown command."
-
- def do_cat(self, arg):
- """dump the contents of a file"""
diff --git a/debian/patches/swig.m4-Do-not-include-ruby-include-subdir.patch b/debian/patches/swig.m4-Do-not-include-ruby-include-subdir.patch
deleted file mode 100644
index 7b02d8b..0000000
--- a/debian/patches/swig.m4-Do-not-include-ruby-include-subdir.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: Dimitri John Ledkov <xnox@ubuntu.com>
-Date: Mon, 23 Mar 2020 23:41:41 -0400
-Subject: swig.m4: Do not include ruby include subdir
-
-It has headers that clash with standard ones, such as assert.h.
-
-Signed-off-by: James McCoy <jamessan@debian.org>
----
- build/ac-macros/swig.m4 | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/build/ac-macros/swig.m4 b/build/ac-macros/swig.m4
-index 3c05797..4031462 100644
---- a/build/ac-macros/swig.m4
-+++ b/build/ac-macros/swig.m4
-@@ -168,7 +168,7 @@ AC_DEFUN(SVN_FIND_SWIG,
- AC_CACHE_CHECK([for Ruby include path], [svn_cv_ruby_includes],[
- if test -d "$rbconfig_rubyhdrdir"; then
- dnl Ruby >=1.9
-- svn_cv_ruby_includes="-I. -I$rbconfig_rubyhdrdir -I$rbconfig_rubyhdrdir/ruby -I$rbconfig_rubyhdrdir/ruby/backward"
-+ svn_cv_ruby_includes="-I. -I$rbconfig_rubyhdrdir -I$rbconfig_rubyhdrdir/ruby/backward"
- if test -d "$rbconfig_rubyarchhdrdir"; then
- dnl Ruby >=2.0
- svn_cv_ruby_includes="$svn_cv_ruby_includes -I$rbconfig_rubyarchhdrdir"
diff --git a/debian/patches/use-python2-as-the-interpreter-now-for-tests-not-python.patch b/debian/patches/use-python3-as-the-interpreter-now-for-tests-not-python.patch
index e071826..505f52b 100644
--- a/debian/patches/use-python2-as-the-interpreter-now-for-tests-not-python.patch
+++ b/debian/patches/use-python3-as-the-interpreter-now-for-tests-not-python.patch
@@ -1,9 +1,9 @@
From: Steve Langasek <steve.langasek@canonical.com>
Date: Sun, 12 Jan 2020 23:25:01 -0800
-Subject: use python2 as the interpreter now for tests, not python
+Subject: use python3 as the interpreter now for tests, not python
/usr/bin/python is no longer guaranteed to exist, per PEP 394. Use
-python2 instead for compatibility.
+python3 instead for compatibility.
Closes: #948770
Signed-off-by: James McCoy <jamessan@debian.org>
@@ -12,12 +12,12 @@ Signed-off-by: James McCoy <jamessan@debian.org>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/subversion/tests/cmdline/svneditor.py b/subversion/tests/cmdline/svneditor.py
-index 7f59987..375fc07 100755
+index 7f59987..4699dc1 100755
--- a/subversion/tests/cmdline/svneditor.py
+++ b/subversion/tests/cmdline/svneditor.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
-+#!/usr/bin/env python2
++#!/usr/bin/env python3
#
# svneditor.py: a mock $SVN_EDITOR for the Subversion test suite
#