summaryrefslogtreecommitdiff
path: root/tools/buildbot/slaves/bb-openbsd/svnclean.sh
diff options
context:
space:
mode:
Diffstat (limited to 'tools/buildbot/slaves/bb-openbsd/svnclean.sh')
-rwxr-xr-xtools/buildbot/slaves/bb-openbsd/svnclean.sh2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/buildbot/slaves/bb-openbsd/svnclean.sh b/tools/buildbot/slaves/bb-openbsd/svnclean.sh
index a2f86e0..553e0f4 100755
--- a/tools/buildbot/slaves/bb-openbsd/svnclean.sh
+++ b/tools/buildbot/slaves/bb-openbsd/svnclean.sh
@@ -22,11 +22,13 @@
set -e
set -x
+svn cleanup ../build
(test -h ../svn-trunk || ln -s build ../svn-trunk)
for i in $(jot - 6 12); do
(test -h ../svn-1.${i}.x || ln -s build ../svn-1.${i}.x)
done
lastchangedrev="$(svn info --show-item=last-changed-revision ../../unix-build/Makefile.svn)"
+svn cleanup ../../unix-build
svn update ../../unix-build
newlastchangedrev="$(svn info --show-item=last-changed-revision ../../unix-build/Makefile.svn)"
(test -h ../GNUmakefile || ln -s ../unix-build/Makefile.svn ../GNUmakefile)