summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Shadura <andrew.shadura@collabora.co.uk>2020-01-18 16:53:24 +0100
committerAndrej Shadura <andrew.shadura@collabora.co.uk>2020-01-18 17:15:26 +0100
commit68d95a893bc2dd47a7d8258a207aa6e34a7198fd (patch)
treeb6d653cf5991cf2feb98e5b6aafb4a4c80835ba9
parent3751d9d2cc97c7bc70f25c43b883590b82003644 (diff)
Pydoctor needs to depend on cachecontrol, but it doesn’t
Since python-cachecontrol has been removed from the archive, work this around by bringing it into the PYTHONPATH from the Python 3 package
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules10
2 files changed, 12 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 0934836d..84f8d6cb 100644
--- a/debian/control
+++ b/debian/control
@@ -13,6 +13,8 @@ Build-Depends: dh-python,
python3-all-dbg,
python-docutils,
python-pydoctor (>= 0.5+git20151204),
+ python3-cachecontrol | python-cachecontrol,
+ python-lockfile,
debhelper-compat (= 12)
Standards-Version: 4.0.0
Vcs-Git: https://salsa.debian.org/python-team/modules/subvertpy.git
diff --git a/debian/rules b/debian/rules
index 38d7dcbf..0f179152 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,10 +17,20 @@ pythonpath = $$(ls -d $(CURDIR)/build/lib.*-$(1))
export PYBUILD_NAME=subvertpy
export HOME=$(CURDIR)/nonexistent
+export PYTHONPATH = debian/fake-python-path
+
%:
CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" \
LDFLAGS="$(LDFLAGS)" dh $* --with python2,python3 --buildsystem=pybuild
+override_dh_auto_configure:
+ mkdir -p debian/fake-python-path
+ [ ! -d /usr/lib/python2.7/dist-packages/cachecontrol ] && \
+ [ -d /usr/lib/python3/dist-packages/cachecontrol ] && \
+ ln -s /usr/lib/python3/dist-packages/cachecontrol debian/fake-python-path/cachecontrol || \
+ true
+ dh_auto_configure
+
override_dh_auto_build:
dh_auto_build
PYTHONHASHSEED=0 $(MAKE) pydoctor