summaryrefslogtreecommitdiff
path: root/autogen.sh
diff options
context:
space:
mode:
authorRoberto C. Sanchez <roberto@connexer.com>2014-03-29 10:53:49 -0400
committerRoberto C. Sanchez <roberto@connexer.com>2014-03-29 10:53:49 -0400
commit8c8aa6b07e595cfac56838b5964ab3e96051f1b2 (patch)
treeda38e2c1979148dbd3b0c7b87f930746f5ba7f44 /autogen.sh
parent8d3fc864d094eeadc721f8e93436b37a5fab173e (diff)
Imported Upstream version 1.5.7
Diffstat (limited to 'autogen.sh')
-rwxr-xr-xautogen.sh49
1 files changed, 9 insertions, 40 deletions
diff --git a/autogen.sh b/autogen.sh
index a8c480b..3daea9a 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -1,49 +1,18 @@
#!/bin/sh
+echo "*** Sword build system generation"
+echo "*** Recreating libtool"
+libtoolize --force --copy;
ACLOCAL="$AUTODIR""aclocal"
echo "*** Recreating aclocal.m4"
echo "$ACLOCAL"
-if $ACLOCAL --version | egrep "1\.5$" >/dev/null 2>&1; then \
- echo "aclocal 1.5" ;
- $ACLOCAL;\
-elif $ACLOCAL --version | egrep "1\.4$" >/dev/null 2>&1; then \
- echo "aclocal 1.4" ;\
- echo "You must have aclocal 1.5 to use aclocal with this \
-source";\
-else \
- echo "aclocal unknown" ;\
- echo "You must have aclocal 1.5 to use aclocal with this \
-source";\
-fi
+ $ACLOCAL;
+
echo "*** Recreating configure"
AUTOCONF="$AUTODIR""autoconf"
AUTOHEAD="$AUTODIR""autoheader"
-if $AUTOCONF --version | egrep "2\.52$" >/dev/null 2>&1; then \
- echo "autoconf 2.52" ;
- if egrep "^AM_CONFIG_HEADER" configure.ac >/dev/null 2>&1; then \
- echo "*** Creating config.h template" ;\
- $AUTOHEAD ;\
- fi
- $AUTOCONF;\
-elif $AUTOCONF --version | egrep "2\.13$" >/dev/null 2>&1; then \
- echo "autoconf 2.13" ;\
- echo "You must have autoconf 2.52 to use autoconf with this \
-source";\
-else \
- echo "autoconf unknown" ;\
- echo "You must have autoconf 2.52 to use autoconf with this \
-source";\
-fi
+ $AUTOHEAD ;
+ $AUTOCONF;
+
echo "*** Recreating the Makefile.in files"
AUTOMAKE="$AUTODIR""automake"
-if $AUTOMAKE --version | egrep "1\.5$" >/dev/null 2>&1; then \
- echo "automake 1.5" ;
- $AUTOMAKE;\
-elif $AUTOMAKE --version | egrep "1\.4$" >/dev/null 2>&1; then \
- echo "automake 1.4" ;\
- echo "You must have automake 1.5 to use automake with this \
-source";\
-else \
- echo "automake unknown" ;\
- echo "You must have automake 1.5 to use automake with this \
-source";\
-fi
+ $AUTOMAKE -ac --foreign;