summaryrefslogtreecommitdiff
path: root/configure
diff options
context:
space:
mode:
authorDaniel Glassey <wdg@debian.org>2015-09-07 11:14:57 +0100
committerDaniel Glassey <wdg@debian.org>2015-09-07 11:14:57 +0100
commit7b6c8b08e9d29332dcd0a1029e7421334bfb6f61 (patch)
treedc263ee8b6c923716a8e0fed64756b7af1238dc7 /configure
parent7a00574163029c0c2b649878c95d5acbd083564a (diff)
Imported Upstream version 1.7.3+dfsg
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure58
1 files changed, 23 insertions, 35 deletions
diff --git a/configure b/configure
index 4f8ab3e..626ddec 100755
--- a/configure
+++ b/configure
@@ -1,7 +1,7 @@
#! /bin/sh
# From configure.ac Revision: 1.45 .
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.69 for sword 1.7.2.
+# Generated by GNU Autoconf 2.69 for sword 1.7.3.
#
# Report bugs to <sword-bugs@crosswire.org>.
#
@@ -591,8 +591,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='sword'
PACKAGE_TARNAME='sword'
-PACKAGE_VERSION='1.7.2'
-PACKAGE_STRING='sword 1.7.2'
+PACKAGE_VERSION='1.7.3'
+PACKAGE_STRING='sword 1.7.3'
PACKAGE_BUGREPORT='sword-bugs@crosswire.org'
PACKAGE_URL='http://crosswire.org/sword'
@@ -680,7 +680,6 @@ AM_CFLAGS
AM_CXXFLAGS
enable_profile
enable_debug
-ICU_VER
dir_confdef
with_conf
with_icusword
@@ -1423,7 +1422,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures sword 1.7.2 to adapt to many kinds of systems.
+\`configure' configures sword 1.7.3 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1494,7 +1493,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of sword 1.7.2:";;
+ short | recursive ) echo "Configuration of sword 1.7.3:";;
esac
cat <<\_ACEOF
@@ -1636,7 +1635,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-sword configure 1.7.2
+sword configure 1.7.3
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@@ -2144,7 +2143,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by sword $as_me 1.7.2, which was
+It was created by sword $as_me 1.7.3, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@@ -3121,7 +3120,7 @@ fi
# Define the identity of the package.
PACKAGE='sword'
- VERSION='1.7.2'
+ VERSION='1.7.3'
cat >>confdefs.h <<_ACEOF
@@ -7218,10 +7217,10 @@ s390*-*linux*|s390*-*tpf*|sparc*-*linux*)
x86_64-*linux*)
LD="${LD-ld} -m elf_i386"
;;
- powerpcle-*linux*)
+ powerpc64le-*linux*)
LD="${LD-ld} -m elf32lppclinux"
;;
- powerpc-*linux*)
+ powerpc64-*linux*)
LD="${LD-ld} -m elf32ppclinux"
;;
s390x-*linux*)
@@ -16629,7 +16628,6 @@ fi
# ---------------------------------------------------------------------
# Find ICU tools
# ---------------------------------------------------------------------
-ICU_VER=
ICU_LIBS=
ICU_IOLIBS=
if test x$with_icu = xyes; then
@@ -16674,28 +16672,18 @@ $as_echo "no" >&6; }
fi
-# The icu-config script was new in icu 2.2
- if test "$ICU_CONFIG" = "no" ; then
- echo "*** The icu-config script installed by icu could not be found"
- echo "*** continuing anyway and assuming 2.1 or earlier"
- ICU_VER="2.1"
- ICU_LIBS="-licui18n -licuuc -licudata"
- ICU_IOLIBS="-lustdio"
- else
- ICU_VER=`$ICU_CONFIG --version`
+ if test "$ICU_CONFIG" != "no" ; then
ICU_LIBS=`$ICU_CONFIG --ldflags`
- #ICU_IOLIBS=`if test $(echo "$ICU_VER >= 3.0"|bc) -eq 1; then $ICU_CONFIG --ldflags-icuio; else $ICU_CONFIG --ldflags-ustdio; fi;`
ICU_IOLIBS=`$ICU_CONFIG --ldflags-icuio`
+ with_icu=yes
+ LIBS="$LIBS $ICU_LIBS $ICU_IOLIBS"
+ AM_CXXFLAGS="$AM_CXXFLAGS -D_ICU_"
+ AM_CFLAGS="$AM_CFLAGS -D_ICU_"
+ else
+ echo "*** The icu-config script installed by icu could not be found"
+ echo "*** compiling without ICU support"
+ with_icu=no
fi
- AM_CXXFLAGS="$AM_CXXFLAGS -D_ICU_"
- AM_CFLAGS="$AM_CFLAGS -D_ICU_"
-fi
-
-if test "x$ICU_LIBS" != x; then
- with_icu=yes
- LIBS="$LIBS $ICU_LIBS $ICU_IOLIBS"
-else
- with_icu=no
fi
@@ -16904,7 +16892,6 @@ SWORD_VERSION_NUM=$V1$V2$V3$V4
-
# ---------------------------------------------------------------------
# Conditional variables
# ---------------------------------------------------------------------
@@ -17050,7 +17037,7 @@ fi
# ---------------------------------------------------------------------
# Final output
# ---------------------------------------------------------------------
-ac_config_files="$ac_config_files Makefile lib/Makefile tests/Makefile tests/cppunit/Makefile utilities/Makefile examples/Makefile examples/cmdline/Makefile utilities/diatheke/Makefile sword.pc include/swversion.h sword.spec"
+ac_config_files="$ac_config_files Makefile lib/Makefile tests/Makefile tests/cppunit/Makefile utilities/Makefile examples/Makefile examples/cmdline/Makefile examples/tasks/Makefile utilities/diatheke/Makefile sword.pc include/swversion.h sword.spec"
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
@@ -17662,7 +17649,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by sword $as_me 1.7.2, which was
+This file was extended by sword $as_me 1.7.3, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -17729,7 +17716,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-sword config.status 1.7.2
+sword config.status 1.7.3
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
@@ -18245,6 +18232,7 @@ do
"utilities/Makefile") CONFIG_FILES="$CONFIG_FILES utilities/Makefile" ;;
"examples/Makefile") CONFIG_FILES="$CONFIG_FILES examples/Makefile" ;;
"examples/cmdline/Makefile") CONFIG_FILES="$CONFIG_FILES examples/cmdline/Makefile" ;;
+ "examples/tasks/Makefile") CONFIG_FILES="$CONFIG_FILES examples/tasks/Makefile" ;;
"utilities/diatheke/Makefile") CONFIG_FILES="$CONFIG_FILES utilities/diatheke/Makefile" ;;
"sword.pc") CONFIG_FILES="$CONFIG_FILES sword.pc" ;;
"include/swversion.h") CONFIG_FILES="$CONFIG_FILES include/swversion.h" ;;