summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorglasseyes <dglassey@gmail.com>2018-11-02 13:31:06 +0700
committerglasseyes <dglassey@gmail.com>2018-11-02 15:34:14 +0700
commit087f7653c74dcb42ee473ca9747e446b5361d17b (patch)
treef76cdb220132b0083eb4746af8cd15abab866174 /debian
parentddee9ecd8b6295534a33aaeeaa423a13d0476e10 (diff)
WIP automake subdir-objects
untgz buffer overflow patch - remove unused strtime
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/0004-automake-subdir-objects.patch41
-rw-r--r--debian/patches/0005-untgz-sprintf.patch29
-rw-r--r--debian/patches/series2
4 files changed, 73 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index f9536e6..3592e41 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-sword (1.8.1-4~pre1) experimental; urgency=medium
+sword (1.8.1-4~pre1) UNRELEASED; urgency=medium
* d/watch file to use https
* d/control don't need libsword-dbg any more
diff --git a/debian/patches/0004-automake-subdir-objects.patch b/debian/patches/0004-automake-subdir-objects.patch
new file mode 100644
index 0000000..f5a47d7
--- /dev/null
+++ b/debian/patches/0004-automake-subdir-objects.patch
@@ -0,0 +1,41 @@
+From: Daniel Glassey <wdg@debian.org>
+Date: Thu, 1 Nov 2018 13:34:07 +0700
+Subject: use subdir-objects in automake
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -11,10 +11,10 @@
+ AC_REVISION($Revision: 1.45 $)
+
+ AC_CANONICAL_TARGET
+-AM_INIT_AUTOMAKE
++#AM_INIT_AUTOMAKE
+
+ # this doesn't work
+-#AM_INIT_AUTOMAKE([subdir-objects])
++AM_INIT_AUTOMAKE([subdir-objects])
+
+ AM_CONFIG_HEADER(include/config.h)
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -4,7 +4,7 @@
+ LDADD = $(top_builddir)/lib/libsword.la
+
+ # Global config directory
+-globalconfdir := @sysconfdir@
++globalconfdir = @sysconfdir@
+
+ SUBDIRS = lib .
+
+--- a/lib/Makefile.am
++++ b/lib/Makefile.am
+@@ -10,7 +10,7 @@
+ AM_CPPFLAGS += -I$(includedir) -DUSE_AUTOTOOLS -DUNIX -Dunix -D__unix__
+
+ # Global config directory
+-globalconfdir := @sysconfdir@
++globalconfdir = @sysconfdir@
+
+ lib_LTLIBRARIES = libsword.la
+
diff --git a/debian/patches/0005-untgz-sprintf.patch b/debian/patches/0005-untgz-sprintf.patch
new file mode 100644
index 0000000..2b6e8da
--- /dev/null
+++ b/debian/patches/0005-untgz-sprintf.patch
@@ -0,0 +1,29 @@
+--- a/src/utilfuns/zlib/untgz.c
++++ b/src/utilfuns/zlib/untgz.c
+@@ -86,7 +86,6 @@
+ void TGZnotfound OF((const char *));
+
+ int getoct OF((char *, int));
+-char *strtime OF((time_t *));
+ int ExprMatch OF((char *,char *));
+
+ int makedir OF((char *));
+@@ -141,18 +140,6 @@
+ return result;
+ }
+
+-char *strtime (time_t *t)
+-{
+- struct tm *local;
+- static char result[32];
+-
+- local = localtime(t);
+- sprintf(result,"%2d/%02d/%4d %02d:%02d:%02d",
+- local->tm_mday, local->tm_mon+1, local->tm_year+1900,
+- local->tm_hour, local->tm_min, local->tm_sec);
+- return result;
+-}
+-
+
+ /* regular expression matching */
+
diff --git a/debian/patches/series b/debian/patches/series
index 52887a0..aa6a9d2 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,5 @@
13_curl.diff
abicompare.patch
0003-use-PKG_PROG_PKG_CONFIG-cross-compilation.patch
+0004-automake-subdir-objects.patch
+0005-untgz-sprintf.patch