summaryrefslogtreecommitdiff
path: root/samples
diff options
context:
space:
mode:
authorDimitri John Ledkov <xnox@ubuntu.com>2014-05-11 22:09:52 +0100
committerDimitri John Ledkov <xnox@ubuntu.com>2014-05-11 22:09:52 +0100
commit3525014850e3800ac7b28fd34e7f7af427f1c620 (patch)
tree3d1b8a17b86cfa9af178ceb818a4dc9daf52a46b /samples
sword (1.7.2+dfsg-2) unstable; urgency=medium
* Correct shared library symlink. (Closes: #747420) # imported from the archive
Diffstat (limited to 'samples')
-rw-r--r--samples/Makefile.am33
-rw-r--r--samples/mods.d/globals.conf2
-rw-r--r--samples/recommended/README24
-rw-r--r--samples/recommended/sword.conf2
4 files changed, 61 insertions, 0 deletions
diff --git a/samples/Makefile.am b/samples/Makefile.am
new file mode 100644
index 0000000..3f64a8f
--- /dev/null
+++ b/samples/Makefile.am
@@ -0,0 +1,33 @@
+EXTRA_DIST += samples/mods.d/globals.conf
+
+modsdatadir = $(pkgdatadir)/mods.d
+
+if INSTCONF
+modsDATA = samples/mods.d/globals.conf
+
+installmodsDATA: $(modsDATA)
+ @$(NORMAL_INSTALL)
+ $(mkinstalldirs) $(DESTDIR)$(modsdatadir)
+ @list='$(modsDATA)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ f="`echo $$p | sed -e 's|^.*/||'`"; \
+ echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(modsdatadir)/$$f"; \
+ $(INSTALL_DATA) $$d$$p $(DESTDIR)$(modsdatadir)/$$f; \
+ done
+
+uninstallmodsDATA:
+ @$(NORMAL_UNINSTALL)
+ @list='$(modsDATA)'; for p in $$list; do \
+ f="`echo $$p | sed -e 's|^.*/||'`"; \
+ echo " rm -f $(DESTDIR)$(modsdatadir)/$$f"; \
+ rm -f $(DESTDIR)$(modsdatadir)/$$f; \
+ done
+else
+installmodsDATA:
+ @$(NORMAL_INSTALL)
+ $(mkinstalldirs) $(DESTDIR)$(modsdatadir) \
+ done
+
+uninstallmodsDATA:
+
+endif
diff --git a/samples/mods.d/globals.conf b/samples/mods.d/globals.conf
new file mode 100644
index 0000000..cd98ab2
--- /dev/null
+++ b/samples/mods.d/globals.conf
@@ -0,0 +1,2 @@
+[Globals]
+
diff --git a/samples/recommended/README b/samples/recommended/README
new file mode 100644
index 0000000..95b49ca
--- /dev/null
+++ b/samples/recommended/README
@@ -0,0 +1,24 @@
+In this configuration, a system-wide file is created
+/etc/sword.conf
+which points to the installation of common sword modules located under:
+/usr/share/sword/
+
+To use, as root, copy the sword.conf file located in this directory to /etc
+
+$ su
+Password: ********
+# cp sword.conf /etc
+
+then create a sword repository under /usr/share
+
+# mkdir /usr/share/sword
+
+You may also want to copy the locales directory to your new sword repository
+
+# cp -R ../../locales.d/ /usr/share/sword
+
+then install modules in /usr/share/sword
+
+# cd /usr/share/sword
+# unzip ~/DownloadedSwordModule.zip
+
diff --git a/samples/recommended/sword.conf b/samples/recommended/sword.conf
new file mode 100644
index 0000000..49ea7ee
--- /dev/null
+++ b/samples/recommended/sword.conf
@@ -0,0 +1,2 @@
+[Install]
+DataPath=/usr/share/sword/