summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorRoberto C. Sanchez <roberto@connexer.com>2014-03-29 10:53:59 -0400
committerRoberto C. Sanchez <roberto@connexer.com>2014-03-29 10:53:59 -0400
commit03134fa5f6f25d92724ce4c183f9bbe12a9e37dc (patch)
tree847326a4de82f0241ac87cbbc427a1b92a696a02 /scripts
parentd7469385b05b9510338407fa123e9ad090f80af6 (diff)
Imported Upstream version 1.5.11
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/backupmake.sh5
-rwxr-xr-xscripts/burncd1
-rwxr-xr-xscripts/demotar1
-rwxr-xr-xscripts/disttar7
-rwxr-xr-xscripts/dlltar1
-rwxr-xr-xscripts/eastonstar1
-rwxr-xr-xscripts/mhctar1
-rwxr-xr-xscripts/mkcd6
-rwxr-xr-xscripts/mkswordbase14
-rwxr-xr-xscripts/mkswordbase242
-rwxr-xr-xscripts/mkswordtar28
-rwxr-xr-xscripts/restoremake.sh5
-rwxr-xr-xscripts/sapphire.cpp65
-rwxr-xr-xscripts/svetar1
-rwxr-xr-xscripts/swordenv1
-rwxr-xr-xscripts/swtxtdsp.bat2
-rwxr-xr-xscripts/vinestar1
-rwxr-xr-xscripts/webtar1
18 files changed, 183 insertions, 0 deletions
diff --git a/scripts/backupmake.sh b/scripts/backupmake.sh
new file mode 100755
index 0000000..8c4db3e
--- /dev/null
+++ b/scripts/backupmake.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+cp Makefile Makefile.sw
+cp lib/Makefile lib/Makefile.sw
+cp tests/Makefile tests/Makefile.sw
+cp utilities/Makefile utilities/Makefile.sw
diff --git a/scripts/burncd b/scripts/burncd
new file mode 100755
index 0000000..bdd8b37
--- /dev/null
+++ b/scripts/burncd
@@ -0,0 +1 @@
+cdrecord -v speed=2 dev=0,0 /mnt/server/space/im.iso
diff --git a/scripts/demotar b/scripts/demotar
new file mode 100755
index 0000000..9093b5b
--- /dev/null
+++ b/scripts/demotar
@@ -0,0 +1 @@
+cd /dosc/usr/troy/src; tar -v -c -p -s -z -f ~/src/multimo4.tgz sword/examples/windoze/delphi20/multimo4/multimod.exe
diff --git a/scripts/disttar b/scripts/disttar
new file mode 100755
index 0000000..70e1a1d
--- /dev/null
+++ b/scripts/disttar
@@ -0,0 +1,7 @@
+REV=`cd ..;basename \`pwd ..\`|cut -d\- -f2`
+cd /; tar cfvz sword-$REV.i386.tar.gz /etc/sword.conf /usr/lib/libsword.* /usr/include/sword/* /usr/bin/cheatah /usr/doc/sword/ /usr/share/sword/mods.d/globals.conf
+
+echo
+echo Did you set legalexport := yes
+echo did you set buildshare := yes
+echo
diff --git a/scripts/dlltar b/scripts/dlltar
new file mode 100755
index 0000000..a93fb3c
--- /dev/null
+++ b/scripts/dlltar
@@ -0,0 +1 @@
+cp /dosc/winnt/system32/sword32.dll ../bin; cd /dosc/usr/troy/src; tar -v -c -p -s -z -f ~/src/dlls.tgz sword/bin/sword32.dll
diff --git a/scripts/eastonstar b/scripts/eastonstar
new file mode 100755
index 0000000..ac3d71a
--- /dev/null
+++ b/scripts/eastonstar
@@ -0,0 +1 @@
+cd /dosc/usr/troy/src/; tar -v -c -p -s -z -f ~/src/eastons.tgz sword/modules/lexdict/rawld/eastons
diff --git a/scripts/mhctar b/scripts/mhctar
new file mode 100755
index 0000000..eea59c4
--- /dev/null
+++ b/scripts/mhctar
@@ -0,0 +1 @@
+cd /dosc/usr/troy/src/; tar -v -c -p -s -z -f ~/src/mhc.tgz sword/modules/comments/rawcom/mhc
diff --git a/scripts/mkcd b/scripts/mkcd
new file mode 100755
index 0000000..6bc7163
--- /dev/null
+++ b/scripts/mkcd
@@ -0,0 +1,6 @@
+REV=`cd ..;basename \`pwd ..\`|cut -d\- -f2`
+chmod +x *
+chmod +x ../apps/X11/cheatah/configure
+chmod +x ../apps/X11/cheatah/missing
+cd ../../..; mkisofs -a -J -o -l -L ./im.iso -r -v -V "SWORD_20000428" /mnt/server/space/swordiso/
+
diff --git a/scripts/mkswordbase b/scripts/mkswordbase
new file mode 100755
index 0000000..93f5931
--- /dev/null
+++ b/scripts/mkswordbase
@@ -0,0 +1,14 @@
+#!/bin/sh
+cd ..
+make distclean
+./usrinst.sh
+make
+
+echo
+echo Please execute the following commands
+echo su
+echo cd ..
+echo "make install; make distclean; exit"
+echo ./mkswordbase2
+echo
+
diff --git a/scripts/mkswordbase2 b/scripts/mkswordbase2
new file mode 100755
index 0000000..0609181
--- /dev/null
+++ b/scripts/mkswordbase2
@@ -0,0 +1,42 @@
+#!/bin/sh
+mkdir /tmp/$$
+cd /tmp/$$
+mkdir etc
+echo [Install] > etc/sword.conf
+echo DataPath=/usr/share/sword >> etc/sword.conf
+echo >> etc/sword.conf
+
+mkdir usr
+mkdir usr/include
+cp -r /usr/include/sword usr/include/sword
+
+mkdir usr/lib
+cp -r /usr/lib/libsword.a /usr/lib/libsword.la usr/lib
+
+mkdir usr/share
+mkdir usr/share/sword
+mkdir usr/share/sword/mods.d
+
+echo [Globals] > usr/share/sword/mods.d/globals.conf
+echo >> usr/share/sword/mods.d/globals.conf
+echo >> usr/share/sword/mods.d/globals.conf
+
+cp -r /usr/share/sword/locales.d usr/share/sword/locales.d
+
+mkdir usr/share/doc
+mkdir usr/share/doc/sword
+
+cd -
+cd ..
+cp -r doc/* /tmp/$$/usr/share/doc/sword/
+cp -r ChangeLog README INSTALL LICENSE examples samples /tmp/$$/usr/share/doc/sword/
+cd -
+cd /tmp/$$
+find . -name CVS -type d -exec rm -rf {} \;
+tar czfv swordbase.tar.gz *
+cd -
+mv /tmp/$$/swordbase.tar.gz ../../
+rm -rf /tmp/$$
+
+cd ../..
+echo swordbase.tar.gz in `pwd`
diff --git a/scripts/mkswordtar b/scripts/mkswordtar
new file mode 100755
index 0000000..f98fe17
--- /dev/null
+++ b/scripts/mkswordtar
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+echo
+echo "*** Autogening main sword engine build system"
+echo
+(cd ..;./autogen.sh)
+
+REV=`cd ..;basename \`pwd ..\`|cut -d\- -f2`
+SWORDVER=`grep "define VERSI" ../include/config.h |cut -f2 -d"\""`
+
+if test `echo $REV` == `echo $SWORDVER`; then
+ chmod +x *
+
+ echo
+ echo "*** Autogening swig bindings build system"
+ echo
+ cd ../bindings/swig/package; ./autogen.sh; cd ../../..;
+
+ echo
+ echo "*** Tarring up" sword-$REV.tar.gz
+ echo
+ cd ..; tar -v -c -p -s -z --exclude sword-$REV/bin --exclude sword-$REV/autom4te.cache --exclude sword-$REV/bindings/swig/package/autom4te.cache -X sword-$REV/distignore -f sword-$REV.tar.gz sword-$REV/*
+
+else
+ echo $"Directory version is $REV, but config.h has $SWORDVER"
+ exit 1
+
+fi
diff --git a/scripts/restoremake.sh b/scripts/restoremake.sh
new file mode 100755
index 0000000..e4bd939
--- /dev/null
+++ b/scripts/restoremake.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+cp Makefile.sw Makefile
+cp lib/Makefile.sw lib/Makefile
+cp tests/Makefile.sw tests/Makefile
+cp utilities/Makefile.sw utilities/Makefile
diff --git a/scripts/sapphire.cpp b/scripts/sapphire.cpp
new file mode 100755
index 0000000..7010bc7
--- /dev/null
+++ b/scripts/sapphire.cpp
@@ -0,0 +1,65 @@
+/******************************************************************************
+ *
+ * Placeholder for the REAL SAPPHIRE II Stream Cipher Files
+ *
+ * The SAPPHIRE II package may be obtained from within the United States or
+ * Canada from:
+ *
+ * http://cryptography.org/cgi-bin/crypto.cgi/libraries/sapphire.zip
+ *
+ *
+ * These files must be placed accordingly:
+ *
+ * .../sword/include/sapphire.h
+ * .../sword/src/modules/common/sapphire.cpp
+ *
+ * If you are outside of these countries, you will have to obtain this package
+ * elsewhere.
+ *
+ */
+
+
+unsigned char sapphire::keyrand(int limit,
+ unsigned char *user_key,
+ unsigned char keysize,
+ unsigned char *rsum,
+ unsigned *keypos)
+ {
+ return keysize;
+ }
+
+void sapphire::initialize(unsigned char *key, unsigned char keysize)
+ {
+ }
+
+void sapphire::hash_init(void)
+ {
+ }
+
+sapphire::sapphire(unsigned char *key, unsigned char keysize)
+ {
+ }
+
+void sapphire::burn(void)
+ {
+ }
+
+sapphire::~sapphire()
+ {
+ }
+
+unsigned char sapphire::encrypt(unsigned char b)
+ {
+ return b;
+ }
+
+unsigned char sapphire::decrypt(unsigned char b)
+ {
+ return b;
+ }
+
+void sapphire::hash_final(unsigned char *hash, // Destination
+ unsigned char hashlength) // Size of hash.
+ {
+ }
+
diff --git a/scripts/svetar b/scripts/svetar
new file mode 100755
index 0000000..f6fad43
--- /dev/null
+++ b/scripts/svetar
@@ -0,0 +1 @@
+cd /dosc/usr/troy/src/; tar -v -c -p -s -z -f ~/src/sve.tgz sword/modules/texts/rawtext/sve sword/modules/texts/rawtext/svetxidx.c
diff --git a/scripts/swordenv b/scripts/swordenv
new file mode 100755
index 0000000..924c739
--- /dev/null
+++ b/scripts/swordenv
@@ -0,0 +1 @@
+export PATH=`dirname \`pwd\``/bin:$PATH
diff --git a/scripts/swtxtdsp.bat b/scripts/swtxtdsp.bat
new file mode 100755
index 0000000..5cb4bf5
--- /dev/null
+++ b/scripts/swtxtdsp.bat
@@ -0,0 +1,2 @@
+pkzip -r -P -a ..\tmp\swtxtdsp.zip \sword\frontend\windoze\delphi20\swtxtdsp\*.*
+
diff --git a/scripts/vinestar b/scripts/vinestar
new file mode 100755
index 0000000..2783b7d
--- /dev/null
+++ b/scripts/vinestar
@@ -0,0 +1 @@
+cd /dosc/usr/troy/src/; tar -v -c -p -s -z -f ~/src/vines.tgz sword/modules/lexdict/rawld/vines
diff --git a/scripts/webtar b/scripts/webtar
new file mode 100755
index 0000000..db263f7
--- /dev/null
+++ b/scripts/webtar
@@ -0,0 +1 @@
+cd /dosc/usr/troy/src/; tar -v -c -p -s -z -f ~/src/webster.tgz sword/modules/texts/rawtext/webster