summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorRoberto C. Sanchez <roberto@connexer.com>2014-03-29 10:53:33 -0400
committerRoberto C. Sanchez <roberto@connexer.com>2014-03-29 10:53:33 -0400
commit8d3fc864d094eeadc721f8e93436b37a5fab173e (patch)
tree05e201c67dca55b4ccdf90ad479a25d95e3b1e63 /scripts
Imported Upstream version 1.5.3
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/backupmake.sh5
-rw-r--r--scripts/burncd1
-rw-r--r--scripts/demotar1
-rwxr-xr-xscripts/disttar7
-rw-r--r--scripts/dlltar1
-rw-r--r--scripts/eastonstar1
-rw-r--r--scripts/mhctar1
-rw-r--r--scripts/mkcd5
-rw-r--r--scripts/mksword6
-rwxr-xr-xscripts/restoremake.sh5
-rw-r--r--scripts/sapphire.cpp73
-rw-r--r--scripts/svetar1
-rw-r--r--scripts/swordenv1
-rwxr-xr-xscripts/swtxtdsp.bat2
-rw-r--r--scripts/vinestar1
-rw-r--r--scripts/webtar1
16 files changed, 112 insertions, 0 deletions
diff --git a/scripts/backupmake.sh b/scripts/backupmake.sh
new file mode 100755
index 0000000..8c4db3e
--- /dev/null
+++ b/scripts/backupmake.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+cp Makefile Makefile.sw
+cp lib/Makefile lib/Makefile.sw
+cp tests/Makefile tests/Makefile.sw
+cp utilities/Makefile utilities/Makefile.sw
diff --git a/scripts/burncd b/scripts/burncd
new file mode 100644
index 0000000..bdd8b37
--- /dev/null
+++ b/scripts/burncd
@@ -0,0 +1 @@
+cdrecord -v speed=2 dev=0,0 /mnt/server/space/im.iso
diff --git a/scripts/demotar b/scripts/demotar
new file mode 100644
index 0000000..9093b5b
--- /dev/null
+++ b/scripts/demotar
@@ -0,0 +1 @@
+cd /dosc/usr/troy/src; tar -v -c -p -s -z -f ~/src/multimo4.tgz sword/examples/windoze/delphi20/multimo4/multimod.exe
diff --git a/scripts/disttar b/scripts/disttar
new file mode 100755
index 0000000..70e1a1d
--- /dev/null
+++ b/scripts/disttar
@@ -0,0 +1,7 @@
+REV=`cd ..;basename \`pwd ..\`|cut -d\- -f2`
+cd /; tar cfvz sword-$REV.i386.tar.gz /etc/sword.conf /usr/lib/libsword.* /usr/include/sword/* /usr/bin/cheatah /usr/doc/sword/ /usr/share/sword/mods.d/globals.conf
+
+echo
+echo Did you set legalexport := yes
+echo did you set buildshare := yes
+echo
diff --git a/scripts/dlltar b/scripts/dlltar
new file mode 100644
index 0000000..a93fb3c
--- /dev/null
+++ b/scripts/dlltar
@@ -0,0 +1 @@
+cp /dosc/winnt/system32/sword32.dll ../bin; cd /dosc/usr/troy/src; tar -v -c -p -s -z -f ~/src/dlls.tgz sword/bin/sword32.dll
diff --git a/scripts/eastonstar b/scripts/eastonstar
new file mode 100644
index 0000000..ac3d71a
--- /dev/null
+++ b/scripts/eastonstar
@@ -0,0 +1 @@
+cd /dosc/usr/troy/src/; tar -v -c -p -s -z -f ~/src/eastons.tgz sword/modules/lexdict/rawld/eastons
diff --git a/scripts/mhctar b/scripts/mhctar
new file mode 100644
index 0000000..eea59c4
--- /dev/null
+++ b/scripts/mhctar
@@ -0,0 +1 @@
+cd /dosc/usr/troy/src/; tar -v -c -p -s -z -f ~/src/mhc.tgz sword/modules/comments/rawcom/mhc
diff --git a/scripts/mkcd b/scripts/mkcd
new file mode 100644
index 0000000..c1a9ee0
--- /dev/null
+++ b/scripts/mkcd
@@ -0,0 +1,5 @@
+REV=`cd ..;basename \`pwd ..\`|cut -d\- -f2`
+chmod +x *
+chmod +x ../apps/X11/cheatah/configure
+chmod +x ../apps/X11/cheatah/missing
+cd ../../..; mkisofs -a -J -o -l -L ./im.iso -r -v -V "SWORD_20000428" /mnt/server/space/swordiso/
diff --git a/scripts/mksword b/scripts/mksword
new file mode 100644
index 0000000..f853d1e
--- /dev/null
+++ b/scripts/mksword
@@ -0,0 +1,6 @@
+REV=`cd ..;basename \`pwd ..\`|cut -d\- -f2`
+chmod +x *
+chmod +x ../apps/X11/cheatah/configure
+chmod +x ../apps/X11/cheatah/missing
+cp sapphire.cpp ../src/modules/common
+cd ../..; tar -v -c -p -s -z --exclude sword-$REV/bin -X sword-$REV/modlist -f sword-$REV.tar.gz sword-$REV/*
diff --git a/scripts/restoremake.sh b/scripts/restoremake.sh
new file mode 100755
index 0000000..e4bd939
--- /dev/null
+++ b/scripts/restoremake.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+cp Makefile.sw Makefile
+cp lib/Makefile.sw lib/Makefile
+cp tests/Makefile.sw tests/Makefile
+cp utilities/Makefile.sw utilities/Makefile
diff --git a/scripts/sapphire.cpp b/scripts/sapphire.cpp
new file mode 100644
index 0000000..63968a4
--- /dev/null
+++ b/scripts/sapphire.cpp
@@ -0,0 +1,73 @@
+/******************************************************************************
+ *
+ * Placeholder for the REAL SAPPHIRE II Stream Cipher Files
+ *
+ * The SAPPHIRE II package may be obtained from within the United States or
+ * Canada from:
+ *
+ * http://cryptography.org/cgi-bin/crypto.cgi/libraries/sapphire.zip
+ *
+ *
+ * These files must be placed accordingly:
+ *
+ * .../sword/include/sapphire.h
+ * .../sword/src/modules/common/sapphire.cpp
+ *
+ * If you are outside of these countries, you will have to obtain this package
+ * elsewhere.
+ *
+ */
+
+
+#ifdef UNIX
+#include <memory.h>
+#include <unistd.h>
+#else
+#include <mem.h>
+#endif
+#include "sapphire.h"
+
+unsigned char sapphire::keyrand(int limit,
+ unsigned char *user_key,
+ unsigned char keysize,
+ unsigned char *rsum,
+ unsigned *keypos)
+ {
+ return keysize;
+ }
+
+void sapphire::initialize(unsigned char *key, unsigned char keysize)
+ {
+ }
+
+void sapphire::hash_init(void)
+ {
+ }
+
+sapphire::sapphire(unsigned char *key, unsigned char keysize)
+ {
+ }
+
+void sapphire::burn(void)
+ {
+ }
+
+sapphire::~sapphire()
+ {
+ }
+
+unsigned char sapphire::encrypt(unsigned char b)
+ {
+ return b;
+ }
+
+unsigned char sapphire::decrypt(unsigned char b)
+ {
+ return b;
+ }
+
+void sapphire::hash_final(unsigned char *hash, // Destination
+ unsigned char hashlength) // Size of hash.
+ {
+ }
+
diff --git a/scripts/svetar b/scripts/svetar
new file mode 100644
index 0000000..f6fad43
--- /dev/null
+++ b/scripts/svetar
@@ -0,0 +1 @@
+cd /dosc/usr/troy/src/; tar -v -c -p -s -z -f ~/src/sve.tgz sword/modules/texts/rawtext/sve sword/modules/texts/rawtext/svetxidx.c
diff --git a/scripts/swordenv b/scripts/swordenv
new file mode 100644
index 0000000..924c739
--- /dev/null
+++ b/scripts/swordenv
@@ -0,0 +1 @@
+export PATH=`dirname \`pwd\``/bin:$PATH
diff --git a/scripts/swtxtdsp.bat b/scripts/swtxtdsp.bat
new file mode 100755
index 0000000..5cb4bf5
--- /dev/null
+++ b/scripts/swtxtdsp.bat
@@ -0,0 +1,2 @@
+pkzip -r -P -a ..\tmp\swtxtdsp.zip \sword\frontend\windoze\delphi20\swtxtdsp\*.*
+
diff --git a/scripts/vinestar b/scripts/vinestar
new file mode 100644
index 0000000..2783b7d
--- /dev/null
+++ b/scripts/vinestar
@@ -0,0 +1 @@
+cd /dosc/usr/troy/src/; tar -v -c -p -s -z -f ~/src/vines.tgz sword/modules/lexdict/rawld/vines
diff --git a/scripts/webtar b/scripts/webtar
new file mode 100644
index 0000000..db263f7
--- /dev/null
+++ b/scripts/webtar
@@ -0,0 +1 @@
+cd /dosc/usr/troy/src/; tar -v -c -p -s -z -f ~/src/webster.tgz sword/modules/texts/rawtext/webster