summaryrefslogtreecommitdiff
path: root/src/modules/common
diff options
context:
space:
mode:
authorRoberto C. Sanchez <roberto@connexer.com>2014-03-29 10:54:02 -0400
committerRoberto C. Sanchez <roberto@connexer.com>2014-03-29 10:54:02 -0400
commit936d9e8484ff73282c8c0a277310d1ffdde86e10 (patch)
tree084d6d2e50f188b0e9c00c109a935efa6ad665fc /src/modules/common
parent71a39f4652cd51df814c930dd268f3c9ad2aee86 (diff)
Imported Upstream version 1.6.1+dfsg
Diffstat (limited to 'src/modules/common')
-rw-r--r--src/modules/common/Makefile.am2
-rw-r--r--src/modules/common/sapphire.cpp4
2 files changed, 1 insertions, 5 deletions
diff --git a/src/modules/common/Makefile.am b/src/modules/common/Makefile.am
index e688094..34a14bf 100644
--- a/src/modules/common/Makefile.am
+++ b/src/modules/common/Makefile.am
@@ -5,7 +5,7 @@ libsword_la_SOURCES += $(commondir)/rawstr4.cpp
libsword_la_SOURCES += $(commondir)/swcomprs.cpp
libsword_la_SOURCES += $(commondir)/lzsscomprs.cpp
-if ZLIB
+if HAVE_LIBZ
SWZLIB = $(commondir)/zipcomprs.cpp
else
SWZLIB =
diff --git a/src/modules/common/sapphire.cpp b/src/modules/common/sapphire.cpp
index a2c5ce0..7b141d2 100644
--- a/src/modules/common/sapphire.cpp
+++ b/src/modules/common/sapphire.cpp
@@ -144,7 +144,6 @@ sapphire::~sapphire()
unsigned char sapphire::encrypt(unsigned char b)
{
-#ifdef USBINARY
// Picture a single enigma rotor with 256 positions, rewired
// on the fly by card-shuffling.
@@ -172,9 +171,6 @@ unsigned char sapphire::encrypt(unsigned char b)
cards[avalanche])&0xFF]];
last_plain = b;
return last_cipher;
-#else
- return b;
-#endif
}
unsigned char sapphire::decrypt(unsigned char b)