summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rw-r--r--debian/patches/08_gcc_43.diff57
-rw-r--r--debian/patches/series1
4 files changed, 67 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 59328ff..2a053ff 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+sword (1.5.9-5) unstable; urgency=low
+
+ * debian/control change libsword-dev dependency to
+ libcurl4-gnutls-dev, Closes: #423936
+ * include patch to build with gcc 4.3, Closes: #417717
+
+ -- Daniel Glassey <wdg@debian.org> Sat, 19 May 2007 16:22:41 -0600
+
sword (1.5.9-4) unstable; urgency=low
* debian/control curl transition, change build dep to
diff --git a/debian/control b/debian/control
index f7f3c50..89bb4a8 100644
--- a/debian/control
+++ b/debian/control
@@ -27,7 +27,7 @@ Description: API/library for bible software
Package: libsword-dev
Architecture: any
Section: libdevel
-Depends: libsword6 (= ${Source-Version}), libc6-dev, libz-dev, libcurl3-gnutls-dev (>= 7.15.0-5.1), libclucene-dev
+Depends: libsword6 (= ${Source-Version}), libc6-dev, libz-dev, libcurl4-gnutls-dev, libclucene-dev
Provides: sword-dev
Description: Development files for libsword
This package contains the static libraries and headers for developing
diff --git a/debian/patches/08_gcc_43.diff b/debian/patches/08_gcc_43.diff
new file mode 100644
index 0000000..3d0373a
--- /dev/null
+++ b/debian/patches/08_gcc_43.diff
@@ -0,0 +1,57 @@
+--- sword-1.5.9.orig/include/flatapi.h 2007-04-04 11:52:31.000000000 +0000
++++ sword-1.5.9/include/flatapi.h 2007-04-04 11:53:30.000000000 +0000
+@@ -27,6 +27,8 @@
+ #ifdef __cplusplus
+ #endif
+
++#include <stdint.h>
++
+ extern "C" {
+
+ #define SWHANDLE intptr_t
+--- sword-1.5.9.orig/src/modules/filters/gbfwordjs.cpp 2007-04-04 11:49:30.000000000 +0000
++++ sword-1.5.9/src/modules/filters/gbfwordjs.cpp 2007-04-04 11:49:45.000000000 +0000
+@@ -8,6 +8,7 @@
+ #include <stdlib.h>
+ #include <gbfwordjs.h>
+ #include <swmodule.h>
++#include <stdio.h>
+ #include <ctype.h>
+ #include <utilstr.h>
+ #include <versekey.h>
+--- sword-1.5.9.orig/utilities/diatheke/corediatheke.h 2007-04-04 11:54:34.000000000 +0000
++++ sword-1.5.9/utilities/diatheke/corediatheke.h 2007-04-04 11:54:42.000000000 +0000
+@@ -4,6 +4,7 @@
+ // see accompanying LICENSE file for license details
+
+ #include <stdio.h>
++#include <ostream>
+
+ #include "diathekemgr.h"
+ #include <localemgr.h>
+--- sword-1.5.9.orig/utilities/diatheke/osiscgi.cpp 2007-04-04 11:56:04.000000000 +0000
++++ sword-1.5.9/utilities/diatheke/osiscgi.cpp 2007-04-04 11:56:16.000000000 +0000
+@@ -14,6 +14,7 @@
+ * *
+ ***************************************************************************/
+
++#include <cctype>
+ #include <stdlib.h>
+ #include "osiscgi.h"
+ #include <utilxml.h>
+--- sword-1.5.9.orig/utilities/stepdump.cpp 2007-04-04 12:01:41.000000000 +0000
++++ sword-1.5.9/utilities/stepdump.cpp 2007-04-04 12:01:49.000000000 +0000
+@@ -1,3 +1,4 @@
++#include <cstdlib>
+ #include <iostream>
+ #include <string>
+
+--- sword-1.5.9.orig/utilities/step2vpl.cpp 2007-04-04 12:02:47.000000000 +0000
++++ sword-1.5.9/utilities/step2vpl.cpp 2007-04-04 12:02:52.000000000 +0000
+@@ -1,3 +1,4 @@
++#include <cstdlib>
+ #include <iostream>
+ #include <string>
+ #include <stdio.h>
+
+
diff --git a/debian/patches/series b/debian/patches/series
index 219bd46..e00641d 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -5,3 +5,4 @@
05_getline.diff
06_warnings.diff
07_warn_tools.diff
+08_gcc_43.diff