summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am52
1 files changed, 42 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index bc4cf1d..3b06273 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
-AUTOMAKE_OPTIONS = 1.5
+AUTOMAKE_OPTIONS = 1.6
# General defines
-version := 1.5.3
+version := 1.5.7
# this WILL NOT WORK for you. only inhouse patched version of
@@ -27,10 +27,6 @@ need_local_regex := no
endif
-# VCL library- set to yes if you would like to build
-buildvcl := @enable_vcl@
-
-
# Debugging options etc...
debug := @enable_debug@
profile := @enable_profile@
@@ -63,23 +59,59 @@ icu := @with_icu@
# Global config directory
globalconfdir := @sysconfdir@
-SUBDIRS = lib . tests utilities examples apps
+SUBDIRS = lib . icu
+if BUILDTESTS
+TESTSDIR = tests
+else
+TESTSDIR =
+endif
+if BUILDUTILS
+UTILSDIR = utilities
+else
+UTILSDIR =
+endif
+if BUILDEXAMPLES
+EXAMPLESDIR = examples
+else
+EXAMPLESDIR =
+endif
+
+SUBDIRS += $(TESTSDIR) $(UTILSDIR) $(EXAMPLESDIR)
+
INCLUDES = -I $(top_srcdir)/include
-EXTRA_DIST = sword.spec sword.kdevprj sword.bmp options.conf
+EXTRA_DIST = sword.spec sword.kdevprj sword.bmp usrinst.sh autogen.sh sword.pc.in
+
+if USE_PKGCONF
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = sword.pc
+
+$(pkgconfig_DATA): config.status
+endif
if INSTCONF
sysconf_DATA = sword.conf
sword.conf:
@echo "[Install]" > sword.conf
@echo "DataPath=$(pkgdatadir)/" >> sword.conf
+
+clean-generic:
+ -rm -f sword.conf
endif
+
noinst_PROGRAMS = testlib
testlib_SOURCES = testlib.cpp
-testlib_LDADD = -L./lib -lsword
+
+if ICU
+iculibs = -licui18n -licuuc
+endif
+
+testlib_LDADD = -L./lib -lsword $(iculibs)
include locales.d/Makefile.am
include samples/Makefile.am
+include debian/Makefile.am
+include doc/Makefile.am
restore:
cd $(top_srcdir) && ./scripts/restoremake.sh
@@ -92,7 +124,7 @@ install: install-recursive
@echo "configuration file. one can be generated to /etc/sword.conf"
@echo "by typing: \"make install_config\""
@echo ""
- @echo "modules (Bible, etc.), may then be unzipped to $(pkgdatadir)/"
+ @echo "modules (Bibles, etc.), may then be unzipped to $(pkgdatadir)/"
@echo ""
@echo "type \"make register\" to help us keep track of how many"
@echo "people are using sword."