summaryrefslogtreecommitdiff
path: root/bindings/swig/README
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/swig/README')
-rw-r--r--bindings/swig/README33
1 files changed, 33 insertions, 0 deletions
diff --git a/bindings/swig/README b/bindings/swig/README
new file mode 100644
index 0000000..9b41f6d
--- /dev/null
+++ b/bindings/swig/README
@@ -0,0 +1,33 @@
+Building the SWIG Bindings
+==========================
+
+You may need to do the following to get this to work. From this directory:
+
+cd package
+
+# Special step for BSD-liks (e.g. Mac OS X):
+# edit autogen.sh to remove the "-a" option from cp
+
+libtoolize --force
+
+./autogen.sh
+./configure
+make
+
+# Rather than make, you probably only care about one of the languages bindings.
+# So you might try one of these pairs of commands instead:
+#
+# make perl_swig
+# make perl_make
+#
+# make python_swig
+# make python_make
+#
+
+# Install the perl bindings
+cd perl
+sudo make install
+
+# Install the python bindings - you may need to run this with sudo
+cd python
+python setup.py install