summaryrefslogtreecommitdiff
path: root/examples/X11/qt/simplefrontend/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'examples/X11/qt/simplefrontend/Makefile')
-rw-r--r--examples/X11/qt/simplefrontend/Makefile42
1 files changed, 0 insertions, 42 deletions
diff --git a/examples/X11/qt/simplefrontend/Makefile b/examples/X11/qt/simplefrontend/Makefile
deleted file mode 100644
index 0bfdf5e..0000000
--- a/examples/X11/qt/simplefrontend/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-
-
-CC = /usr/bin/egcs
-CFLAGS = -g -I$(QTDIR)/include -I/usr/lib/qt/include -I../../../../include
-LFLAGS = -L$(QTDIR)/lib -lqt -L/usr/X11R6/lib -lXext -lX11 -L../../../../lib -lsword -lstdc++
-
-MOCSRC = ./simplefrontend/SimpleFrontEndProject.h
-MOC_CC = ./hSimpleFrontEndProject.cpp
-MOC_OBJ = ./hSimpleFrontEndProject.o
-
-SRC = ./SimpleFrontEndProject.cpp ./main.cpp
-OBJ = $(MOC_CC) ./SimpleFrontEndProject.o ./main.o
-TARGET = simplefrontend
-.SUFFIXES: .cpp
-
-.cpp.o: $(SRC)
- $(CC) $(CFLAGS) -c $*.cpp -o $@
-
-all: $(TARGET)
-
-tarclean:
- rm -f $(TARGET) core
-
-clean:
- rm -f $(OBJ) $(MOC_CC) $(TARGET)
-
-distclean: clean
- rm -f core *~ $(TARGET)
-
-$(TARGET): tarclean $(MOC_CC) $(OBJ)
- rm -f $(TARGET)
- $(CC) $(CFLAGS) -o $(TARGET) $(OBJ) $(LFLAGS)
-
-./hSimpleFrontEndProject.cpp: ./SimpleFrontEndProject.h
- moc ./SimpleFrontEndProject.h -o ./hSimpleFrontEndProject.cpp
-
-./SimpleFrontEndProject.o: ./SimpleFrontEndProject.h
-
-just-clean: clean
-just-pre:
-
-just-targets: $(TARGET)