summaryrefslogtreecommitdiff
path: root/examples/cmdline
diff options
context:
space:
mode:
Diffstat (limited to 'examples/cmdline')
-rw-r--r--examples/cmdline/Makefile360
-rw-r--r--examples/cmdline/Makefile.am4
-rw-r--r--examples/cmdline/Makefile.in298
-rw-r--r--examples/cmdline/lookup.cpp33
-rw-r--r--examples/cmdline/search.cpp41
-rwxr-xr-xexamples/cmdline/threaded_search.cpp38
6 files changed, 285 insertions, 489 deletions
diff --git a/examples/cmdline/Makefile b/examples/cmdline/Makefile
deleted file mode 100644
index af9522b..0000000
--- a/examples/cmdline/Makefile
+++ /dev/null
@@ -1,360 +0,0 @@
-# Makefile.in generated by automake 1.6 from Makefile.am.
-# examples/cmdline/Makefile. Generated from Makefile.in by configure.
-
-# Copyright 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002
-# Free Software Foundation, Inc.
-# This Makefile.in is free software; the Free Software Foundation
-# gives unlimited permission to copy and/or distribute it,
-# with or without modifications, as long as this notice is preserved.
-
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
-# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
-# PARTICULAR PURPOSE.
-
-
-SHELL = /bin/sh
-
-srcdir = .
-top_srcdir = ../..
-
-prefix = /usr
-exec_prefix = ${prefix}
-
-bindir = ${exec_prefix}/bin
-sbindir = ${exec_prefix}/sbin
-libexecdir = ${exec_prefix}/libexec
-datadir = ${prefix}/share
-sysconfdir = /etc
-sharedstatedir = ${prefix}/com
-localstatedir = ${prefix}/var
-libdir = ${exec_prefix}/lib
-infodir = ${prefix}/info
-mandir = ${prefix}/man
-includedir = ${prefix}/include
-oldincludedir = /usr/include
-pkgdatadir = $(datadir)/sword
-pkglibdir = $(libdir)/sword
-pkgincludedir = $(includedir)/sword
-top_builddir = ../..
-
-ACLOCAL = ${SHELL} /space/home/scribe/src/sword/missing --run aclocal
-AUTOCONF = ${SHELL} /space/home/scribe/src/sword/missing --run autoconf
-AUTOMAKE = ${SHELL} /space/home/scribe/src/sword/missing --run automake
-AUTOHEADER = ${SHELL} /space/home/scribe/src/sword/missing --run autoheader
-
-am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
-INSTALL = /usr/bin/install -c
-INSTALL_PROGRAM = ${INSTALL}
-INSTALL_DATA = ${INSTALL} -m 644
-install_sh_DATA = $(install_sh) -c -m 644
-install_sh_PROGRAM = $(install_sh) -c
-INSTALL_SCRIPT = ${INSTALL}
-INSTALL_HEADER = $(INSTALL_DATA)
-transform = s,x,x,
-NORMAL_INSTALL = :
-PRE_INSTALL = :
-POST_INSTALL = :
-NORMAL_UNINSTALL = :
-PRE_UNINSTALL = :
-POST_UNINSTALL = :
-host_alias =
-host_triplet = i686-pc-linux-gnu
-
-EXEEXT =
-OBJEXT = o
-PATH_SEPARATOR = :
-AMTAR = ${SHELL} /space/home/scribe/src/sword/missing --run tar
-AS = @AS@
-AWK = gawk
-CC = gcc
-CXX = g++
-DEPDIR = .deps
-DLLTOOL = @DLLTOOL@
-ECHO = echo
-INSTALL_STRIP_PROGRAM = ${SHELL} $(install_sh) -c -s
-LIBTOOL = $(SHELL) $(top_builddir)/libtool
-LN_S = ln -s
-MAINT = #
-OBJDUMP = @OBJDUMP@
-PACKAGE = sword
-RANLIB = ranlib
-STRIP = strip
-VERSION = 1.5.3
-am__include = include
-am__quote =
-dir_confdef = no
-enable_debug = no
-enable_profile = yes
-enable_vcl = no
-install_sh = /space/home/scribe/src/sword/install-sh
-target_cpu = i686
-target_mingw32 = no
-target_os = linux-gnu
-target_system = intel
-target_vendor = pc
-with_conf = no
-with_icu = no
-with_zlib = yes
-AUTOMAKE_OPTIONS = 1.5
-INCLUDES = -I $(top_srcdir)/include
-LDADD = -L$(top_builddir)/lib -lsword
-
-noinst_PROGRAMS = lookup search threaded_search
-
-lookup_SOURCES = lookup.cpp
-search_SOURCES = search.cpp
-threaded_search_SOURCES = threaded_search.cpp
-threaded_search_LDADD = $(LDADD) -lpthread
-subdir = examples/cmdline
-mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
-CONFIG_HEADER = $(top_builddir)/config.h
-CONFIG_CLEAN_FILES =
-noinst_PROGRAMS = lookup$(EXEEXT) search$(EXEEXT) \
- threaded_search$(EXEEXT)
-PROGRAMS = $(noinst_PROGRAMS)
-
-am_lookup_OBJECTS = lookup.$(OBJEXT)
-lookup_OBJECTS = $(am_lookup_OBJECTS)
-lookup_LDADD = $(LDADD)
-lookup_DEPENDENCIES =
-lookup_LDFLAGS =
-am_search_OBJECTS = search.$(OBJEXT)
-search_OBJECTS = $(am_search_OBJECTS)
-search_LDADD = $(LDADD)
-search_DEPENDENCIES =
-search_LDFLAGS =
-am_threaded_search_OBJECTS = threaded_search.$(OBJEXT)
-threaded_search_OBJECTS = $(am_threaded_search_OBJECTS)
-threaded_search_DEPENDENCIES =
-threaded_search_LDFLAGS =
-
-DEFS = -DHAVE_CONFIG_H
-DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
-CPPFLAGS =
-LDFLAGS =
-LIBS = -lstdc++ -lz
-depcomp = $(SHELL) $(top_srcdir)/depcomp
-am__depfiles_maybe = depfiles
-DEP_FILES = ./$(DEPDIR)/lookup.Po ./$(DEPDIR)/search.Po \
- ./$(DEPDIR)/threaded_search.Po
-CXXCOMPILE = $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
- $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
-LTCXXCOMPILE = $(LIBTOOL) --mode=compile $(CXX) $(DEFS) \
- $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
- $(AM_CXXFLAGS) $(CXXFLAGS)
-CXXLD = $(CXX)
-CXXLINK = $(LIBTOOL) --mode=link $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) \
- $(AM_LDFLAGS) $(LDFLAGS) -o $@
-CXXFLAGS = -g -O2 -ftemplate-depth-25 -pg
-DIST_SOURCES = $(lookup_SOURCES) $(search_SOURCES) \
- $(threaded_search_SOURCES)
-DIST_COMMON = Makefile.am Makefile.in
-SOURCES = $(lookup_SOURCES) $(search_SOURCES) $(threaded_search_SOURCES)
-
-all: all-am
-
-.SUFFIXES:
-.SUFFIXES: .cpp .lo .o .obj
-
-mostlyclean-libtool:
- -rm -f *.lo
-
-clean-libtool:
- -rm -rf .libs _libs
-
-distclean-libtool:
- -rm -f libtool
-$(srcdir)/Makefile.in: # Makefile.am $(top_srcdir)/configure.ac $(ACLOCAL_M4)
- cd $(top_srcdir) && \
- $(AUTOMAKE) --gnu examples/cmdline/Makefile
-Makefile: # $(srcdir)/Makefile.in $(top_builddir)/config.status
- cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)
-
-clean-noinstPROGRAMS:
- -test -z "$(noinst_PROGRAMS)" || rm -f $(noinst_PROGRAMS)
-lookup$(EXEEXT): $(lookup_OBJECTS) $(lookup_DEPENDENCIES)
- @rm -f lookup$(EXEEXT)
- $(CXXLINK) $(lookup_LDFLAGS) $(lookup_OBJECTS) $(lookup_LDADD) $(LIBS)
-search$(EXEEXT): $(search_OBJECTS) $(search_DEPENDENCIES)
- @rm -f search$(EXEEXT)
- $(CXXLINK) $(search_LDFLAGS) $(search_OBJECTS) $(search_LDADD) $(LIBS)
-threaded_search$(EXEEXT): $(threaded_search_OBJECTS) $(threaded_search_DEPENDENCIES)
- @rm -f threaded_search$(EXEEXT)
- $(CXXLINK) $(threaded_search_LDFLAGS) $(threaded_search_OBJECTS) $(threaded_search_LDADD) $(LIBS)
-
-mostlyclean-compile:
- -rm -f *.$(OBJEXT) core *.core
-
-distclean-compile:
- -rm -f *.tab.c
-
-include ./$(DEPDIR)/lookup.Po
-include ./$(DEPDIR)/search.Po
-include ./$(DEPDIR)/threaded_search.Po
-
-distclean-depend:
- -rm -rf ./$(DEPDIR)
-
-.cpp.o:
- source='$<' object='$@' libtool=no \
- depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' \
- $(CXXDEPMODE) $(depcomp) \
- $(CXXCOMPILE) -c -o $@ `test -f $< || echo '$(srcdir)/'`$<
-
-.cpp.obj:
- source='$<' object='$@' libtool=no \
- depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' \
- $(CXXDEPMODE) $(depcomp) \
- $(CXXCOMPILE) -c -o $@ `cygpath -w $<`
-
-.cpp.lo:
- source='$<' object='$@' libtool=yes \
- depfile='$(DEPDIR)/$*.Plo' tmpdepfile='$(DEPDIR)/$*.TPlo' \
- $(CXXDEPMODE) $(depcomp) \
- $(LTCXXCOMPILE) -c -o $@ `test -f $< || echo '$(srcdir)/'`$<
-CXXDEPMODE = depmode=gcc3
-uninstall-info-am:
-
-ETAGS = etags
-ETAGSFLAGS =
-
-tags: TAGS
-
-ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
- list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
- unique=`for i in $$list; do \
- if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
- done | \
- $(AWK) ' { files[$$0] = 1; } \
- END { for (i in files) print i; }'`; \
- mkid -fID $$unique
-
-TAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
- $(TAGS_FILES) $(LISP)
- tags=; \
- here=`pwd`; \
- list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
- unique=`for i in $$list; do \
- if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
- done | \
- $(AWK) ' { files[$$0] = 1; } \
- END { for (i in files) print i; }'`; \
- test -z "$(ETAGS_ARGS)$$tags$$unique" \
- || $(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
- $$tags $$unique
-
-GTAGS:
- here=`$(am__cd) $(top_builddir) && pwd` \
- && cd $(top_srcdir) \
- && gtags -i $(GTAGS_ARGS) $$here
-
-distclean-tags:
- -rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH
-DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
-
-top_distdir = ../..
-distdir = $(top_distdir)/$(PACKAGE)-$(VERSION)
-
-distdir: $(DISTFILES)
- @for file in $(DISTFILES); do \
- if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
- dir=`echo "$$file" | sed -e 's,/[^/]*$$,,'`; \
- if test "$$dir" != "$$file" && test "$$dir" != "."; then \
- dir="/$$dir"; \
- $(mkinstalldirs) "$(distdir)$$dir"; \
- else \
- dir=''; \
- fi; \
- if test -d $$d/$$file; then \
- cp -pR $$d/$$file $(distdir)$$dir \
- || exit 1; \
- else \
- test -f $(distdir)/$$file \
- || cp -p $$d/$$file $(distdir)/$$file \
- || exit 1; \
- fi; \
- done
-check-am: all-am
-check: check-am
-all-am: Makefile $(PROGRAMS)
-
-installdirs:
-
-install: install-am
-install-exec: install-exec-am
-install-data: install-data-am
-uninstall: uninstall-am
-
-install-am: all-am
- @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
-
-installcheck: installcheck-am
-install-strip:
- $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
- INSTALL_STRIP_FLAG=-s \
- `test -z '$(STRIP)' || \
- echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
-mostlyclean-generic:
-
-clean-generic:
-
-distclean-generic:
- -rm -f Makefile $(CONFIG_CLEAN_FILES) stamp-h stamp-h[0-9]*
-
-maintainer-clean-generic:
- @echo "This command is intended for maintainers to use"
- @echo "it deletes files that may require special tools to rebuild."
-clean: clean-am
-
-clean-am: clean-generic clean-libtool clean-noinstPROGRAMS \
- mostlyclean-am
-
-distclean: distclean-am
-
-distclean-am: clean-am distclean-compile distclean-depend \
- distclean-generic distclean-libtool distclean-tags
-
-dvi: dvi-am
-
-dvi-am:
-
-info: info-am
-
-info-am:
-
-install-data-am:
-
-install-exec-am:
-
-install-info: install-info-am
-
-install-man:
-
-installcheck-am:
-
-maintainer-clean: maintainer-clean-am
-
-maintainer-clean-am: distclean-am maintainer-clean-generic
-
-mostlyclean: mostlyclean-am
-
-mostlyclean-am: mostlyclean-compile mostlyclean-generic \
- mostlyclean-libtool
-
-uninstall-am: uninstall-info-am
-
-.PHONY: GTAGS all all-am check check-am clean clean-generic \
- clean-libtool clean-noinstPROGRAMS distclean distclean-compile \
- distclean-depend distclean-generic distclean-libtool \
- distclean-tags distdir dvi dvi-am info info-am install \
- install-am install-data install-data-am install-exec \
- install-exec-am install-info install-info-am install-man \
- install-strip installcheck installcheck-am installdirs \
- maintainer-clean maintainer-clean-generic mostlyclean \
- mostlyclean-compile mostlyclean-generic mostlyclean-libtool \
- tags uninstall uninstall-am uninstall-info-am
-
-# Tell versions [3.59,3.63) of GNU make to not export all variables.
-# Otherwise a system limit (for SysV at least) may be exceeded.
-.NOEXPORT:
diff --git a/examples/cmdline/Makefile.am b/examples/cmdline/Makefile.am
index 7f9f6a6..dcf4e48 100644
--- a/examples/cmdline/Makefile.am
+++ b/examples/cmdline/Makefile.am
@@ -1,6 +1,6 @@
-AUTOMAKE_OPTIONS = 1.5
+AUTOMAKE_OPTIONS = 1.6
INCLUDES = -I $(top_srcdir)/include
-LDADD = -L$(top_builddir)/lib -lsword
+LDADD = $(top_builddir)/lib/libsword.la
noinst_PROGRAMS = lookup search threaded_search
diff --git a/examples/cmdline/Makefile.in b/examples/cmdline/Makefile.in
index 9d42d53..bfef0b6 100644
--- a/examples/cmdline/Makefile.in
+++ b/examples/cmdline/Makefile.in
@@ -1,7 +1,7 @@
-# Makefile.in generated by automake 1.6 from Makefile.am.
+# Makefile.in generated by automake 1.7.4 from Makefile.am.
# @configure_input@
-# Copyright 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002
+# Copyright 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003
# Free Software Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
@@ -13,81 +13,160 @@
# PARTICULAR PURPOSE.
@SET_MAKE@
-SHELL = @SHELL@
srcdir = @srcdir@
top_srcdir = @top_srcdir@
VPATH = @srcdir@
-prefix = @prefix@
-exec_prefix = @exec_prefix@
-
-bindir = @bindir@
-sbindir = @sbindir@
-libexecdir = @libexecdir@
-datadir = @datadir@
-sysconfdir = @sysconfdir@
-sharedstatedir = @sharedstatedir@
-localstatedir = @localstatedir@
-libdir = @libdir@
-infodir = @infodir@
-mandir = @mandir@
-includedir = @includedir@
-oldincludedir = /usr/include
pkgdatadir = $(datadir)/@PACKAGE@
pkglibdir = $(libdir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
top_builddir = ../..
-ACLOCAL = @ACLOCAL@
-AUTOCONF = @AUTOCONF@
-AUTOMAKE = @AUTOMAKE@
-AUTOHEADER = @AUTOHEADER@
-
am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
INSTALL = @INSTALL@
-INSTALL_PROGRAM = @INSTALL_PROGRAM@
-INSTALL_DATA = @INSTALL_DATA@
install_sh_DATA = $(install_sh) -c -m 644
install_sh_PROGRAM = $(install_sh) -c
-INSTALL_SCRIPT = @INSTALL_SCRIPT@
+install_sh_SCRIPT = $(install_sh) -c
INSTALL_HEADER = $(INSTALL_DATA)
-transform = @program_transform_name@
+transform = $(program_transform_name)
NORMAL_INSTALL = :
PRE_INSTALL = :
POST_INSTALL = :
NORMAL_UNINSTALL = :
PRE_UNINSTALL = :
POST_UNINSTALL = :
-host_alias = @host_alias@
host_triplet = @host@
-
-EXEEXT = @EXEEXT@
-OBJEXT = @OBJEXT@
-PATH_SEPARATOR = @PATH_SEPARATOR@
+ACLOCAL = @ACLOCAL@
+AMDEP_FALSE = @AMDEP_FALSE@
+AMDEP_TRUE = @AMDEP_TRUE@
AMTAR = @AMTAR@
-AS = @AS@
+AUTOCONF = @AUTOCONF@
+AUTOHEADER = @AUTOHEADER@
+AUTOMAKE = @AUTOMAKE@
AWK = @AWK@
+BUILDEXAMPLES_FALSE = @BUILDEXAMPLES_FALSE@
+BUILDEXAMPLES_TRUE = @BUILDEXAMPLES_TRUE@
+BUILDTESTS_FALSE = @BUILDTESTS_FALSE@
+BUILDTESTS_TRUE = @BUILDTESTS_TRUE@
+BUILDUTILS_FALSE = @BUILDUTILS_FALSE@
+BUILDUTILS_TRUE = @BUILDUTILS_TRUE@
CC = @CC@
+CCDEPMODE = @CCDEPMODE@
+CFLAGS = @CFLAGS@
+CONFDEF_FALSE = @CONFDEF_FALSE@
+CONFDEF_TRUE = @CONFDEF_TRUE@
+CPPFLAGS = @CPPFLAGS@
+CURL_CFLAGS = @CURL_CFLAGS@
+CURL_CONFIG = @CURL_CONFIG@
+CURL_LIBS = @CURL_LIBS@
CXX = @CXX@
+CXXCPP = @CXXCPP@
+CXXDEPMODE = @CXXDEPMODE@
+CXXFLAGS = @CXXFLAGS@
+CYGPATH_W = @CYGPATH_W@
+DEFS = @DEFS@
DEPDIR = @DEPDIR@
-DLLTOOL = @DLLTOOL@
ECHO = @ECHO@
+ECHO_C = @ECHO_C@
+ECHO_N = @ECHO_N@
+ECHO_T = @ECHO_T@
+EGREP = @EGREP@
+EXEEXT = @EXEEXT@
+GENCCODE = @GENCCODE@
+GENCMN = @GENCMN@
+GENRB = @GENRB@
+ICUSWORD_FALSE = @ICUSWORD_FALSE@
+ICUSWORD_TRUE = @ICUSWORD_TRUE@
+ICU_CONFIG = @ICU_CONFIG@
+ICU_FALSE = @ICU_FALSE@
+ICU_IOLIBS = @ICU_IOLIBS@
+ICU_LIBS = @ICU_LIBS@
+ICU_TRUE = @ICU_TRUE@
+ICU_VER = @ICU_VER@
+INSTALLMGR_FALSE = @INSTALLMGR_FALSE@
+INSTALLMGR_TRUE = @INSTALLMGR_TRUE@
+INSTALL_DATA = @INSTALL_DATA@
+INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+INSTCONF_FALSE = @INSTCONF_FALSE@
+INSTCONF_TRUE = @INSTCONF_TRUE@
+LDFLAGS = @LDFLAGS@
+LIBOBJS = @LIBOBJS@
+LIBS = @LIBS@
LIBTOOL = @LIBTOOL@
LN_S = @LN_S@
+LTLIBOBJS = @LTLIBOBJS@
+LUCENE_LIBS = @LUCENE_LIBS@
MAINT = @MAINT@
-OBJDUMP = @OBJDUMP@
+MAINTAINER_MODE_FALSE = @MAINTAINER_MODE_FALSE@
+MAINTAINER_MODE_TRUE = @MAINTAINER_MODE_TRUE@
+MAKEINFO = @MAKEINFO@
+MINGW_FALSE = @MINGW_FALSE@
+MINGW_TRUE = @MINGW_TRUE@
+OBJEXT = @OBJEXT@
PACKAGE = @PACKAGE@
+PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
+PACKAGE_NAME = @PACKAGE_NAME@
+PACKAGE_STRING = @PACKAGE_STRING@
+PACKAGE_TARNAME = @PACKAGE_TARNAME@
+PACKAGE_VERSION = @PACKAGE_VERSION@
+PATH_SEPARATOR = @PATH_SEPARATOR@
+PKGDATA = @PKGDATA@
+PKG_CONFIG = @PKG_CONFIG@
RANLIB = @RANLIB@
+SET_MAKE = @SET_MAKE@
+SHELL = @SHELL@
STRIP = @STRIP@
+USELUCENE_FALSE = @USELUCENE_FALSE@
+USELUCENE_TRUE = @USELUCENE_TRUE@
+USE_PKGCONF_FALSE = @USE_PKGCONF_FALSE@
+USE_PKGCONF_TRUE = @USE_PKGCONF_TRUE@
VERSION = @VERSION@
+ZLIB_FALSE = @ZLIB_FALSE@
+ZLIB_TRUE = @ZLIB_TRUE@
+ac_ct_CC = @ac_ct_CC@
+ac_ct_CXX = @ac_ct_CXX@
+ac_ct_RANLIB = @ac_ct_RANLIB@
+ac_ct_STRIP = @ac_ct_STRIP@
+am__fastdepCC_FALSE = @am__fastdepCC_FALSE@
+am__fastdepCC_TRUE = @am__fastdepCC_TRUE@
+am__fastdepCXX_FALSE = @am__fastdepCXX_FALSE@
+am__fastdepCXX_TRUE = @am__fastdepCXX_TRUE@
am__include = @am__include@
+am__leading_dot = @am__leading_dot@
am__quote = @am__quote@
+bindir = @bindir@
+build = @build@
+build_alias = @build_alias@
+build_cpu = @build_cpu@
+build_os = @build_os@
+build_vendor = @build_vendor@
+datadir = @datadir@
dir_confdef = @dir_confdef@
enable_debug = @enable_debug@
enable_profile = @enable_profile@
-enable_vcl = @enable_vcl@
+exec_prefix = @exec_prefix@
+host = @host@
+host_alias = @host_alias@
+host_cpu = @host_cpu@
+host_os = @host_os@
+host_vendor = @host_vendor@
+includedir = @includedir@
+infodir = @infodir@
install_sh = @install_sh@
+libdir = @libdir@
+libexecdir = @libexecdir@
+localstatedir = @localstatedir@
+mandir = @mandir@
+oldincludedir = @oldincludedir@
+prefix = @prefix@
+program_transform_name = @program_transform_name@
+sbindir = @sbindir@
+sharedstatedir = @sharedstatedir@
+sysconfdir = @sysconfdir@
+target = @target@
+target_alias = @target_alias@
target_cpu = @target_cpu@
target_mingw32 = @target_mingw32@
target_os = @target_os@
@@ -96,9 +175,9 @@ target_vendor = @target_vendor@
with_conf = @with_conf@
with_icu = @with_icu@
with_zlib = @with_zlib@
-AUTOMAKE_OPTIONS = 1.5
+AUTOMAKE_OPTIONS = 1.6
INCLUDES = -I $(top_srcdir)/include
-LDADD = -L$(top_builddir)/lib -lsword
+LDADD = $(top_builddir)/lib/libsword.la
noinst_PROGRAMS = lookup search threaded_search
@@ -107,6 +186,7 @@ search_SOURCES = search.cpp
threaded_search_SOURCES = threaded_search.cpp
threaded_search_LDADD = $(LDADD) -lpthread
subdir = examples/cmdline
+ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = $(top_builddir)/config.h
CONFIG_CLEAN_FILES =
@@ -117,23 +197,19 @@ PROGRAMS = $(noinst_PROGRAMS)
am_lookup_OBJECTS = lookup.$(OBJEXT)
lookup_OBJECTS = $(am_lookup_OBJECTS)
lookup_LDADD = $(LDADD)
-lookup_DEPENDENCIES =
+lookup_DEPENDENCIES = $(top_builddir)/lib/libsword.la
lookup_LDFLAGS =
am_search_OBJECTS = search.$(OBJEXT)
search_OBJECTS = $(am_search_OBJECTS)
search_LDADD = $(LDADD)
-search_DEPENDENCIES =
+search_DEPENDENCIES = $(top_builddir)/lib/libsword.la
search_LDFLAGS =
am_threaded_search_OBJECTS = threaded_search.$(OBJEXT)
threaded_search_OBJECTS = $(am_threaded_search_OBJECTS)
-threaded_search_DEPENDENCIES =
+threaded_search_DEPENDENCIES = $(top_builddir)/lib/libsword.la
threaded_search_LDFLAGS =
-DEFS = @DEFS@
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
-CPPFLAGS = @CPPFLAGS@
-LDFLAGS = @LDFLAGS@
-LIBS = @LIBS@
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
@AMDEP_TRUE@DEP_FILES = ./$(DEPDIR)/lookup.Po ./$(DEPDIR)/search.Po \
@@ -146,7 +222,6 @@ LTCXXCOMPILE = $(LIBTOOL) --mode=compile $(CXX) $(DEFS) \
CXXLD = $(CXX)
CXXLINK = $(LIBTOOL) --mode=link $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
-CXXFLAGS = @CXXFLAGS@
DIST_SOURCES = $(lookup_SOURCES) $(search_SOURCES) \
$(threaded_search_SOURCES)
DIST_COMMON = Makefile.am Makefile.in
@@ -156,23 +231,18 @@ all: all-am
.SUFFIXES:
.SUFFIXES: .cpp .lo .o .obj
-
-mostlyclean-libtool:
- -rm -f *.lo
-
-clean-libtool:
- -rm -rf .libs _libs
-
-distclean-libtool:
- -rm -f libtool
$(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ Makefile.am $(top_srcdir)/configure.ac $(ACLOCAL_M4)
cd $(top_srcdir) && \
- $(AUTOMAKE) --gnu examples/cmdline/Makefile
+ $(AUTOMAKE) --foreign examples/cmdline/Makefile
Makefile: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.in $(top_builddir)/config.status
cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)
clean-noinstPROGRAMS:
- -test -z "$(noinst_PROGRAMS)" || rm -f $(noinst_PROGRAMS)
+ @list='$(noinst_PROGRAMS)'; for p in $$list; do \
+ f=`echo $$p|sed 's/$(EXEEXT)$$//'`; \
+ echo " rm -f $$p $$f"; \
+ rm -f $$p $$f ; \
+ done
lookup$(EXEEXT): $(lookup_OBJECTS) $(lookup_DEPENDENCIES)
@rm -f lookup$(EXEEXT)
$(CXXLINK) $(lookup_LDFLAGS) $(lookup_OBJECTS) $(lookup_LDADD) $(LIBS)
@@ -197,28 +267,54 @@ distclean-depend:
-rm -rf ./$(DEPDIR)
.cpp.o:
-@AMDEP_TRUE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
-@AMDEP_TRUE@ depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' @AMDEPBACKSLASH@
-@AMDEP_TRUE@ $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
- $(CXXCOMPILE) -c -o $@ `test -f $< || echo '$(srcdir)/'`$<
+@am__fastdepCXX_TRUE@ if $(CXXCOMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" \
+@am__fastdepCXX_TRUE@ -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<; \
+@am__fastdepCXX_TRUE@ then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; \
+@am__fastdepCXX_TRUE@ else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; \
+@am__fastdepCXX_TRUE@ fi
+@AMDEP_TRUE@@am__fastdepCXX_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCXX_FALSE@ depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCXX_FALSE@ $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+@am__fastdepCXX_FALSE@ $(CXXCOMPILE) -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
.cpp.obj:
-@AMDEP_TRUE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
-@AMDEP_TRUE@ depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' @AMDEPBACKSLASH@
-@AMDEP_TRUE@ $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
- $(CXXCOMPILE) -c -o $@ `cygpath -w $<`
+@am__fastdepCXX_TRUE@ if $(CXXCOMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" \
+@am__fastdepCXX_TRUE@ -c -o $@ `if test -f '$<'; then $(CYGPATH_W) '$<'; else $(CYGPATH_W) '$(srcdir)/$<'; fi`; \
+@am__fastdepCXX_TRUE@ then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; \
+@am__fastdepCXX_TRUE@ else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; \
+@am__fastdepCXX_TRUE@ fi
+@AMDEP_TRUE@@am__fastdepCXX_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCXX_FALSE@ depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCXX_FALSE@ $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+@am__fastdepCXX_FALSE@ $(CXXCOMPILE) -c -o $@ `if test -f '$<'; then $(CYGPATH_W) '$<'; else $(CYGPATH_W) '$(srcdir)/$<'; fi`
.cpp.lo:
-@AMDEP_TRUE@ source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
-@AMDEP_TRUE@ depfile='$(DEPDIR)/$*.Plo' tmpdepfile='$(DEPDIR)/$*.TPlo' @AMDEPBACKSLASH@
-@AMDEP_TRUE@ $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
- $(LTCXXCOMPILE) -c -o $@ `test -f $< || echo '$(srcdir)/'`$<
-CXXDEPMODE = @CXXDEPMODE@
+@am__fastdepCXX_TRUE@ if $(LTCXXCOMPILE) -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" \
+@am__fastdepCXX_TRUE@ -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<; \
+@am__fastdepCXX_TRUE@ then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Plo"; \
+@am__fastdepCXX_TRUE@ else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; \
+@am__fastdepCXX_TRUE@ fi
+@AMDEP_TRUE@@am__fastdepCXX_FALSE@ source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCXX_FALSE@ depfile='$(DEPDIR)/$*.Plo' tmpdepfile='$(DEPDIR)/$*.TPlo' @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCXX_FALSE@ $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+@am__fastdepCXX_FALSE@ $(LTCXXCOMPILE) -c -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
+
+mostlyclean-libtool:
+ -rm -f *.lo
+
+clean-libtool:
+ -rm -rf .libs _libs
+
+distclean-libtool:
+ -rm -f libtool
uninstall-info-am:
ETAGS = etags
ETAGSFLAGS =
+CTAGS = ctags
+CTAGSFLAGS =
+
tags: TAGS
ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
@@ -244,20 +340,41 @@ TAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
|| $(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
$$tags $$unique
+ctags: CTAGS
+CTAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
+ $(TAGS_FILES) $(LISP)
+ tags=; \
+ here=`pwd`; \
+ list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
+ unique=`for i in $$list; do \
+ if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
+ done | \
+ $(AWK) ' { files[$$0] = 1; } \
+ END { for (i in files) print i; }'`; \
+ test -z "$(CTAGS_ARGS)$$tags$$unique" \
+ || $(CTAGS) $(CTAGSFLAGS) $(AM_CTAGSFLAGS) $(CTAGS_ARGS) \
+ $$tags $$unique
+
GTAGS:
here=`$(am__cd) $(top_builddir) && pwd` \
&& cd $(top_srcdir) \
&& gtags -i $(GTAGS_ARGS) $$here
distclean-tags:
- -rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH
+ -rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
top_distdir = ../..
distdir = $(top_distdir)/$(PACKAGE)-$(VERSION)
distdir: $(DISTFILES)
- @for file in $(DISTFILES); do \
+ @srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
+ topsrcdirstrip=`echo "$(top_srcdir)" | sed 's|.|.|g'`; \
+ list='$(DISTFILES)'; for file in $$list; do \
+ case $$file in \
+ $(srcdir)/*) file=`echo "$$file" | sed "s|^$$srcdirstrip/||"`;; \
+ $(top_srcdir)/*) file=`echo "$$file" | sed "s|^$$topsrcdirstrip/|$(top_builddir)/|"`;; \
+ esac; \
if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
dir=`echo "$$file" | sed -e 's,/[^/]*$$,,'`; \
if test "$$dir" != "$$file" && test "$$dir" != "."; then \
@@ -267,8 +384,10 @@ distdir: $(DISTFILES)
dir=''; \
fi; \
if test -d $$d/$$file; then \
- cp -pR $$d/$$file $(distdir)$$dir \
- || exit 1; \
+ if test -d $(srcdir)/$$file && test $$d != $(srcdir); then \
+ cp -pR $(srcdir)/$$file $(distdir)$$dir || exit 1; \
+ fi; \
+ cp -pR $$d/$$file $(distdir)$$dir || exit 1; \
else \
test -f $(distdir)/$$file \
|| cp -p $$d/$$file $(distdir)/$$file \
@@ -300,7 +419,7 @@ mostlyclean-generic:
clean-generic:
distclean-generic:
- -rm -f Makefile $(CONFIG_CLEAN_FILES) stamp-h stamp-h[0-9]*
+ -rm -f Makefile $(CONFIG_CLEAN_FILES)
maintainer-clean-generic:
@echo "This command is intended for maintainers to use"
@@ -342,18 +461,27 @@ mostlyclean: mostlyclean-am
mostlyclean-am: mostlyclean-compile mostlyclean-generic \
mostlyclean-libtool
+pdf: pdf-am
+
+pdf-am:
+
+ps: ps-am
+
+ps-am:
+
uninstall-am: uninstall-info-am
-.PHONY: GTAGS all all-am check check-am clean clean-generic \
- clean-libtool clean-noinstPROGRAMS distclean distclean-compile \
- distclean-depend distclean-generic distclean-libtool \
- distclean-tags distdir dvi dvi-am info info-am install \
- install-am install-data install-data-am install-exec \
- install-exec-am install-info install-info-am install-man \
- install-strip installcheck installcheck-am installdirs \
- maintainer-clean maintainer-clean-generic mostlyclean \
- mostlyclean-compile mostlyclean-generic mostlyclean-libtool \
- tags uninstall uninstall-am uninstall-info-am
+.PHONY: CTAGS GTAGS all all-am check check-am clean clean-generic \
+ clean-libtool clean-noinstPROGRAMS ctags distclean \
+ distclean-compile distclean-depend distclean-generic \
+ distclean-libtool distclean-tags distdir dvi dvi-am info \
+ info-am install install-am install-data install-data-am \
+ install-exec install-exec-am install-info install-info-am \
+ install-man install-strip installcheck installcheck-am \
+ installdirs maintainer-clean maintainer-clean-generic \
+ mostlyclean mostlyclean-compile mostlyclean-generic \
+ mostlyclean-libtool pdf pdf-am ps ps-am tags uninstall \
+ uninstall-am uninstall-info-am
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/examples/cmdline/lookup.cpp b/examples/cmdline/lookup.cpp
index a244fb3..502ca52 100644
--- a/examples/cmdline/lookup.cpp
+++ b/examples/cmdline/lookup.cpp
@@ -1,8 +1,18 @@
#include <stdio.h>
-#include <iostream.h>
+#include <iostream>
#include <stdlib.h>
#include <swmgr.h>
+#ifndef NO_SWORD_NAMESPACE
+using sword::SWMgr;
+using sword::SWModule;
+using sword::ModMap;
+using sword::SWKey;
+using sword::AttributeTypeList;
+using sword::AttributeValue;
+using sword::AttributeList;
+#endif
+
int main(int argc, char **argv)
{
SWMgr manager;
@@ -25,27 +35,28 @@ int main(int argc, char **argv)
target = (*it).second;
- target->SetKey(argv[2]);
+ target->setKey(argv[2]);
(const char *)*target; // force an entry lookup to resolve key so we
// get the idxbuf entry for the key
- cout << (const char *)(SWKey &)*target << ":\n";
- cout << target->StripText();
- cout << "\n";
- cout << "==========================\n";
- cout << "Entry Attributes:\n\n";
+ std::cout << (const char *)(SWKey &)*target << ":\n";
+// std::cout << target->StripText();
+ std::cout << target->getRawEntry();
+ std::cout << "\n";
+ std::cout << "==========================\n";
+ std::cout << "Entry Attributes:\n\n";
AttributeTypeList::iterator i1;
AttributeList::iterator i2;
AttributeValue::iterator i3;
for (i1 = target->getEntryAttributes().begin(); i1 != target->getEntryAttributes().end(); i1++) {
- cout << "[ " << i1->first << " ]\n";
+ std::cout << "[ " << i1->first << " ]\n";
for (i2 = i1->second.begin(); i2 != i1->second.end(); i2++) {
- cout << "\t[ " << i2->first << " ]\n";
+ std::cout << "\t[ " << i2->first << " ]\n";
for (i3 = i2->second.begin(); i3 != i2->second.end(); i3++) {
- cout << "\t\t" << i3->first << " = " << i3->second << "\n";
+ std::cout << "\t\t" << i3->first << " = " << i3->second << "\n";
}
}
}
- cout << endl;
+ std::cout << std::endl;
return 0;
}
diff --git a/examples/cmdline/search.cpp b/examples/cmdline/search.cpp
index 519a3f2..72110ee 100644
--- a/examples/cmdline/search.cpp
+++ b/examples/cmdline/search.cpp
@@ -1,34 +1,42 @@
#include <stdio.h>
#include <rawtext.h>
#include <swmgr.h>
+#include <markupfiltmgr.h>
#include <regex.h> // GNU
+#include <iostream>
+
+#ifndef NO_SWORD_NAMESPACE
+using namespace sword;
+#endif
void percentUpdate(char percent, void *userData) {
static char printed = 0;
char maxHashes = *((char *)userData);
while ((((float)percent)/100) * maxHashes > printed) {
- cout << "=";
+ std::cout << "=";
printed++;
- cout.flush();
+ std::cout.flush();
}
/*
- cout << (int)percent << "% ";
+ std::cout << (int)percent << "% ";
*/
- cout.flush();
+ std::cout.flush();
}
int main(int argc, char **argv)
{
- SWMgr manager;
+ SWMgr manager(0, 0, true, new MarkupFilterMgr(FMT_RTF, ENC_RTF));
+// SWMgr manager;
SWModule *target;
ListKey listkey;
- VerseKey vk;
+ ListKey scope;
+ VerseKey parser;
ModMap::iterator it;
- if ((argc != 3) && (argc != 5)) {
- fprintf(stderr, "usage: %s <modname> <\"search string\"> [\"min\" \"max\"]\n", argv[0]);
+ if ((argc != 3) && (argc != 4)) {
+ fprintf(stderr, "usage: %s <modname> <\"search string\"> [\"search_scope\"]\n", argv[0]);
exit(-1);
}
@@ -43,19 +51,18 @@ int main(int argc, char **argv)
target = (*it).second;
- if (argc == 5) { // if min / max specified
- vk.LowerBound(argv[3]);
- vk.UpperBound(argv[4]);
- vk.Persist(1);
- target->SetKey(vk);
+ if (argc == 4) { // if min / max specified
+ scope = parser.ParseVerseList(argv[3], parser, true);
+ scope.Persist(1);
+ target->setKey(scope);
}
- cout << "[0=================================50===============================100]\n ";
+ std::cout << "[0=================================50===============================100]\n ";
char lineLen = 70;
- listkey = target->Search(argv[2], -2, 0/*REG_ICASE*/, 0, 0, &percentUpdate, &lineLen);
- cout << "\n";
+ listkey = target->Search(argv[2], -3, 0/*REG_ICASE*/, 0, 0, &percentUpdate, &lineLen);
+ std::cout << "\n";
while (!listkey.Error()) {
- cout << (const char *)listkey << "\n";
+ std::cout << (const char *)listkey << std::endl;
listkey++;
}
diff --git a/examples/cmdline/threaded_search.cpp b/examples/cmdline/threaded_search.cpp
index 2db9d30..450ca8b 100755
--- a/examples/cmdline/threaded_search.cpp
+++ b/examples/cmdline/threaded_search.cpp
@@ -3,9 +3,19 @@
#include <swmgr.h>
#include <regex.h> // GNU
#include <listkey.h>
+#include <iostream>
#include <pthread.h>
+#ifndef NO_SWORD_NAMESPACE
+using sword::SWMgr;
+using sword::ListKey;
+using sword::SWModule;
+using sword::VerseKey;
+using sword::SWKey;
+using sword::ModMap;
+#endif
+
int cms_currentProgress;
class CSwordModuleSearch {
@@ -31,7 +41,7 @@ void* dummy(void* p) {
void percentUpdate(char percent, void* userData) {
cms_currentProgress = (int)percent;
- cout << cms_currentProgress << "% ";
+ std::cout << cms_currentProgress << "% ";
}
CSwordModuleSearch::CSwordModuleSearch() {
@@ -45,8 +55,8 @@ CSwordModuleSearch::~CSwordModuleSearch() {
}
void CSwordModuleSearch::startThread() {
- cout << "startThread" << endl;
- cout.flush();
+ std::cout << "startThread" << std::endl;
+ std::cout.flush();
pthread_attr_t* attr = new pthread_attr_t;
pthread_attr_init(attr);
@@ -56,27 +66,27 @@ void CSwordModuleSearch::startThread() {
m_isSearching = true;
int i = pthread_create(thread, attr, &dummy, this);
- cout << "Created the thread: " << i << endl;
- cout.flush();
+ std::cout << "Created the thread: " << i << std::endl;
+ std::cout.flush();
}
void CSwordModuleSearch::search() {
if (!m_module) {
- cout << "Return." << endl;
+ std::cout << "Return." << std::endl;
return;
}
ListKey scopeList = VerseKey().ParseVerseList("Luke;John;Revelation","", true);
for (int i=0; i < scopeList.Count(); ++i) {
- cout << (const char*)*scopeList.GetElement(i) << endl;
+ std::cout << (const char*)*scopeList.GetElement(i) << std::endl;
}
SWKey* scope = &scopeList;
m_searchResult = m_module->Search(m_searchedText, -2, REG_ICASE, scope, 0, &percentUpdate);
if (!scope)
- cout << "bad scope!" << endl;
+ std::cout << "bad scope!" << std::endl;
m_isSearching = false;
}
@@ -105,18 +115,18 @@ int main(int argc, char **argv) {
moduleSearch->m_module = (*it).second;
moduleSearch->startThread();
- cout << "Start loop" << endl;
- cout.flush();
+ std::cout << "Start loop" << std::endl;
+ std::cout.flush();
while (true) {
if (!moduleSearch->m_isSearching)
break;
else
- cout.flush();
+ std::cout.flush();
};
- cout << endl << "Number of found items: " << moduleSearch->m_searchResult.Count() << endl;
- cout << "Finished program" << endl;
- cout.flush();
+ std::cout << std::endl << "Number of found items: " << moduleSearch->m_searchResult.Count() << std::endl;
+ std::cout << "Finished program" << std::endl;
+ std::cout.flush();
delete moduleSearch;
exit(0);