summaryrefslogtreecommitdiff
path: root/icu/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'icu/Makefile.in')
-rw-r--r--icu/Makefile.in123
1 files changed, 73 insertions, 50 deletions
diff --git a/icu/Makefile.in b/icu/Makefile.in
index 3bfbfd4..dab792b 100644
--- a/icu/Makefile.in
+++ b/icu/Makefile.in
@@ -1,8 +1,9 @@
-# Makefile.in generated by automake 1.10.2 from Makefile.am.
+# Makefile.in generated by automake 1.11 from Makefile.am.
# @configure_input@
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
-# 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
+# 2003, 2004, 2005, 2006, 2007, 2008, 2009 Free Software Foundation,
+# Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
@@ -16,8 +17,9 @@
VPATH = @srcdir@
pkgdatadir = $(datadir)/@PACKAGE@
-pkglibdir = $(libdir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
+pkglibdir = $(libdir)/@PACKAGE@
+pkglibexecdir = $(libexecdir)/@PACKAGE@
am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
install_sh_DATA = $(install_sh) -c -m 644
install_sh_PROGRAM = $(install_sh) -c
@@ -37,15 +39,14 @@ subdir = icu
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/acx_clucene.m4 \
- $(top_srcdir)/m4/cppunit.m4 $(top_srcdir)/m4/libtool.m4 \
- $(top_srcdir)/m4/ltoptions.m4 $(top_srcdir)/m4/ltsugar.m4 \
- $(top_srcdir)/m4/ltversion.m4 $(top_srcdir)/m4/lt~obsolete.m4 \
+ $(top_srcdir)/m4/colored-echo.m4 $(top_srcdir)/m4/cppunit.m4 \
$(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = $(top_builddir)/include/config.h
CONFIG_CLEAN_FILES =
+CONFIG_CLEAN_VPATH_FILES =
SOURCES =
DIST_SOURCES =
am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
@@ -53,9 +54,23 @@ am__vpath_adj = case $$p in \
$(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
*) f=$$p;; \
esac;
-am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
+am__strip_dir = f=`echo $$p | sed -e 's|^.*/||'`;
+am__install_max = 40
+am__nobase_strip_setup = \
+ srcdirstrip=`echo "$(srcdir)" | sed 's/[].[^$$\\*|]/\\\\&/g'`
+am__nobase_strip = \
+ for p in $$list; do echo "$$p"; done | sed -e "s|$$srcdirstrip/||"
+am__nobase_list = $(am__nobase_strip_setup); \
+ for p in $$list; do echo "$$p $$p"; done | \
+ sed "s| $$srcdirstrip/| |;"' / .*\//!s/ .*/ ./; s,\( .*\)/[^/]*$$,\1,' | \
+ $(AWK) 'BEGIN { files["."] = "" } { files[$$2] = files[$$2] " " $$1; \
+ if (++n[$$2] == $(am__install_max)) \
+ { print $$2, files[$$2]; n[$$2] = 0; files[$$2] = "" } } \
+ END { for (dir in files) print dir, files[dir] }'
+am__base_list = \
+ sed '$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;$$!N;s/\n/ /g' | \
+ sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
am__installdirs = "$(DESTDIR)$(swicudir)"
-swicuDATA_INSTALL = $(INSTALL_DATA)
DATA = $(swicu_DATA)
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
ACLOCAL = @ACLOCAL@
@@ -77,7 +92,6 @@ CPPFLAGS = @CPPFLAGS@
CPPUNIT_CFLAGS = @CPPUNIT_CFLAGS@
CPPUNIT_CONFIG = @CPPUNIT_CONFIG@
CPPUNIT_LIBS = @CPPUNIT_LIBS@
-CURL_AM_CFLAGS = @CURL_AM_CFLAGS@
CURL_CONFIG = @CURL_CONFIG@
CURL_LIBS = @CURL_LIBS@
CXX = @CXX@
@@ -89,13 +103,14 @@ DEFS = @DEFS@
DEPDIR = @DEPDIR@
DLLTOOL = @DLLTOOL@
DSYMUTIL = @DSYMUTIL@
-DUMPBIN = @DUMPBIN@
+ECHO = @ECHO@
ECHO_C = @ECHO_C@
ECHO_N = @ECHO_N@
ECHO_T = @ECHO_T@
EGREP = @EGREP@
EXEEXT = @EXEEXT@
-FGREP = @FGREP@
+F77 = @F77@
+FFLAGS = @FFLAGS@
GENCCODE = @GENCCODE@
GENCMN = @GENCMN@
GENRB = @GENRB@
@@ -109,23 +124,18 @@ INSTALL_DATA = @INSTALL_DATA@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
-LD = @LD@
LDFLAGS = @LDFLAGS@
LIBOBJS = @LIBOBJS@
LIBS = @LIBS@
LIBTOOL = @LIBTOOL@
-LIPO = @LIPO@
LN_S = @LN_S@
LTLIBOBJS = @LTLIBOBJS@
MAINT = @MAINT@
MAKEINFO = @MAKEINFO@
MKDIR_P = @MKDIR_P@
-NM = @NM@
NMEDIT = @NMEDIT@
OBJDUMP = @OBJDUMP@
OBJEXT = @OBJEXT@
-OTOOL = @OTOOL@
-OTOOL64 = @OTOOL64@
PACKAGE = @PACKAGE@
PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
PACKAGE_NAME = @PACKAGE_NAME@
@@ -141,14 +151,13 @@ SET_MAKE = @SET_MAKE@
SHELL = @SHELL@
STRIP = @STRIP@
VERSION = @VERSION@
-XML_LIBS = @XML_LIBS@
abs_builddir = @abs_builddir@
abs_srcdir = @abs_srcdir@
abs_top_builddir = @abs_top_builddir@
abs_top_srcdir = @abs_top_srcdir@
ac_ct_CC = @ac_ct_CC@
ac_ct_CXX = @ac_ct_CXX@
-ac_ct_DUMPBIN = @ac_ct_DUMPBIN@
+ac_ct_F77 = @ac_ct_F77@
am__include = @am__include@
am__leading_dot = @am__leading_dot@
am__quote = @am__quote@
@@ -182,7 +191,6 @@ libdir = @libdir@
libexecdir = @libexecdir@
localedir = @localedir@
localstatedir = @localstatedir@
-lt_ECHO = @lt_ECHO@
mandir = @mandir@
mkdir_p = @mkdir_p@
oldincludedir = @oldincludedir@
@@ -206,23 +214,16 @@ top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
with_conf = @with_conf@
with_icu = @with_icu@
+with_icusword = @with_icusword@
with_zlib = @with_zlib@
AUTOMAKE_OPTIONS = 1.6
-#swicuSOURCES += translit_HTMLEnt_Unicode.txt
-#swicuSOURCES += translit_Han_Pinyin.txt
-#swicuSOURCES += translit_Kanji_English.txt
-#swicuSOURCES += translit_Kanji_OnRomaji.txt
swicuSOURCES = translit_BETA_Greek.txt translit_BGreek_Greek.txt \
translit_CCAT_Hebrew.txt translit_CCAT_Syriac.txt \
- translit_Latin_Armenian.txt translit_Latin_Coptic.txt \
- translit_Latin_Ethiopic.txt translit_Latin_Georgian.txt \
- translit_Latin_Gothic.txt translit_Latin_Syriac.txt \
- translit_Latin_Thai.txt translit_Latin_Ugaritic.txt \
- translit_Any_Latin1.txt translit_Any_Latex.txt \
- translit_Latin_Arabic.txt translit_Latin_Hebrew.txt \
- translit_swordindex.txt
-@ICU_FALSE@swicu_DATA =
-@ICU_TRUE@swicu_DATA = $(swicuSOURCES:.txt=.res)
+ translit_Latin_Coptic.txt translit_Latin_Gothic.txt \
+ translit_Latin_Ugaritic.txt translit_Any_Latin1.txt \
+ translit_Any_Latex.txt translit_swordindex.txt
+@HAVE_ICU_FALSE@swicu_DATA =
+@HAVE_ICU_TRUE@swicu_DATA = $(swicuSOURCES:.txt=.res)
EXTRA_DIST = $(swicuSOURCES)
CLEANFILES = *.res *.lst *.mk *.mak swicu.dat
SUFFIXES = .txt .res .dat
@@ -244,8 +245,8 @@ SUFFIXES = .txt .res .dat
# echo " rm -f $(DESTDIR)$(swicudir)/$$f"; \
# rm -f $(DESTDIR)$(swicudir)/$$f; \
# done
-@ICU_FALSE@swicudir = $(pkglibdir)
-@ICU_TRUE@swicudir = $(pkglibdir)/${VERSION}_icu_${ICU_VER}
+@HAVE_ICU_FALSE@swicudir = $(pkglibdir)
+@HAVE_ICU_TRUE@swicudir = $(pkglibdir)/${VERSION}_icu_${ICU_VER}
all: all-am
.SUFFIXES:
@@ -259,9 +260,9 @@ $(srcdir)/Makefile.in: @MAINTAINER_MODE_TRUE@ $(srcdir)/Makefile.am $(am__confi
exit 1;; \
esac; \
done; \
- echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign icu/Makefile'; \
- cd $(top_srcdir) && \
- $(AUTOMAKE) --foreign icu/Makefile
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign icu/Makefile'; \
+ $(am__cd) $(top_srcdir) && \
+ $(AUTOMAKE) --foreign icu/Makefile
.PRECIOUS: Makefile
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
@case '$?' in \
@@ -279,6 +280,7 @@ $(top_srcdir)/configure: @MAINTAINER_MODE_TRUE@ $(am__configure_deps)
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
$(ACLOCAL_M4): @MAINTAINER_MODE_TRUE@ $(am__aclocal_m4_deps)
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+$(am__aclocal_m4_deps):
mostlyclean-libtool:
-rm -f *.lo
@@ -288,20 +290,23 @@ clean-libtool:
install-swicuDATA: $(swicu_DATA)
@$(NORMAL_INSTALL)
test -z "$(swicudir)" || $(MKDIR_P) "$(DESTDIR)$(swicudir)"
- @list='$(swicu_DATA)'; for p in $$list; do \
+ @list='$(swicu_DATA)'; test -n "$(swicudir)" || list=; \
+ for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
- f=$(am__strip_dir) \
- echo " $(swicuDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(swicudir)/$$f'"; \
- $(swicuDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(swicudir)/$$f"; \
+ echo "$$d$$p"; \
+ done | $(am__base_list) | \
+ while read files; do \
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(swicudir)'"; \
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(swicudir)" || exit $$?; \
done
uninstall-swicuDATA:
@$(NORMAL_UNINSTALL)
- @list='$(swicu_DATA)'; for p in $$list; do \
- f=$(am__strip_dir) \
- echo " rm -f '$(DESTDIR)$(swicudir)/$$f'"; \
- rm -f "$(DESTDIR)$(swicudir)/$$f"; \
- done
+ @list='$(swicu_DATA)'; test -n "$(swicudir)" || list=; \
+ files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
+ test -n "$$files" || exit 0; \
+ echo " ( cd '$(DESTDIR)$(swicudir)' && rm -f" $$files ")"; \
+ cd "$(DESTDIR)$(swicudir)" && rm -f $$files
tags: TAGS
TAGS:
@@ -325,13 +330,17 @@ distdir: $(DISTFILES)
if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
if test -d $$d/$$file; then \
dir=`echo "/$$file" | sed -e 's,/[^/]*$$,,'`; \
+ if test -d "$(distdir)/$$file"; then \
+ find "$(distdir)/$$file" -type d ! -perm -700 -exec chmod u+rwx {} \;; \
+ fi; \
if test -d $(srcdir)/$$file && test $$d != $(srcdir); then \
- cp -pR $(srcdir)/$$file $(distdir)$$dir || exit 1; \
+ cp -fpR $(srcdir)/$$file "$(distdir)$$dir" || exit 1; \
+ find "$(distdir)/$$file" -type d ! -perm -700 -exec chmod u+rwx {} \;; \
fi; \
- cp -pR $$d/$$file $(distdir)$$dir || exit 1; \
+ cp -fpR $$d/$$file "$(distdir)$$dir" || exit 1; \
else \
- test -f $(distdir)/$$file \
- || cp -p $$d/$$file $(distdir)/$$file \
+ test -f "$(distdir)/$$file" \
+ || cp -p $$d/$$file "$(distdir)/$$file" \
|| exit 1; \
fi; \
done
@@ -363,6 +372,7 @@ clean-generic:
distclean-generic:
-test -z "$(CONFIG_CLEAN_FILES)" || rm -f $(CONFIG_CLEAN_FILES)
+ -test . = "$(srcdir)" || test -z "$(CONFIG_CLEAN_VPATH_FILES)" || rm -f $(CONFIG_CLEAN_VPATH_FILES)
maintainer-clean-generic:
@echo "This command is intended for maintainers to use"
@@ -381,6 +391,8 @@ dvi-am:
html: html-am
+html-am:
+
info: info-am
info-am:
@@ -389,18 +401,28 @@ install-data-am: install-swicuDATA
install-dvi: install-dvi-am
+install-dvi-am:
+
install-exec-am:
install-html: install-html-am
+install-html-am:
+
install-info: install-info-am
+install-info-am:
+
install-man:
install-pdf: install-pdf-am
+install-pdf-am:
+
install-ps: install-ps-am
+install-ps-am:
+
installcheck-am:
maintainer-clean: maintainer-clean-am
@@ -442,6 +464,7 @@ uninstall-am: uninstall-swicuDATA
#installswicu_DATA:
#
#uninstallswicu_DATA:
+
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT: