summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 0000000..bb7758c
--- /dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,21 @@
+AUTOMAKE_OPTIONS = 1.5
+INCLUDES = -I$(top_srcdir)/include
+DEFS += -DUSE_AUTOTOOLS
+
+# Global config directory
+globalconfdir := @sysconfdir@
+
+lib_LTLIBRARIES = libsword.la
+
+libsword_la_SOURCES =
+libsword_la_LIBADD =
+libsword_la_LDFLAGS = -version-info 1
+
+include ../src/keys/Makefile.am
+include ../src/utilfuns/Makefile.am
+include ../src/mgr/Makefile.am
+include ../src/frontend/Makefile.am
+include ../src/modules/Makefile.am
+include ../bindings/Makefile.am
+include ../include/Makefile.am
+