summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/backupmake.sh5
-rwxr-xr-xscripts/mkswordtar4
-rwxr-xr-xscripts/restoremake.sh5
-rwxr-xr-xscripts/sapphire.cpp65
4 files changed, 3 insertions, 76 deletions
diff --git a/scripts/backupmake.sh b/scripts/backupmake.sh
deleted file mode 100755
index 8c4db3e..0000000
--- a/scripts/backupmake.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-cp Makefile Makefile.sw
-cp lib/Makefile lib/Makefile.sw
-cp tests/Makefile tests/Makefile.sw
-cp utilities/Makefile utilities/Makefile.sw
diff --git a/scripts/mkswordtar b/scripts/mkswordtar
index f98fe17..e510b50 100755
--- a/scripts/mkswordtar
+++ b/scripts/mkswordtar
@@ -8,7 +8,9 @@ echo
REV=`cd ..;basename \`pwd ..\`|cut -d\- -f2`
SWORDVER=`grep "define VERSI" ../include/config.h |cut -f2 -d"\""`
-if test `echo $REV` == `echo $SWORDVER`; then
+sed -i "s/^\(PROJECT_NUMBER\).*/\1 = \"$SWORDVER\"/" ../doc/Doxyfile
+
+if [ "$REV" = "$SWORDVER" ]; then
chmod +x *
echo
diff --git a/scripts/restoremake.sh b/scripts/restoremake.sh
deleted file mode 100755
index e4bd939..0000000
--- a/scripts/restoremake.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-cp Makefile.sw Makefile
-cp lib/Makefile.sw lib/Makefile
-cp tests/Makefile.sw tests/Makefile
-cp utilities/Makefile.sw utilities/Makefile
diff --git a/scripts/sapphire.cpp b/scripts/sapphire.cpp
deleted file mode 100755
index 7010bc7..0000000
--- a/scripts/sapphire.cpp
+++ /dev/null
@@ -1,65 +0,0 @@
-/******************************************************************************
- *
- * Placeholder for the REAL SAPPHIRE II Stream Cipher Files
- *
- * The SAPPHIRE II package may be obtained from within the United States or
- * Canada from:
- *
- * http://cryptography.org/cgi-bin/crypto.cgi/libraries/sapphire.zip
- *
- *
- * These files must be placed accordingly:
- *
- * .../sword/include/sapphire.h
- * .../sword/src/modules/common/sapphire.cpp
- *
- * If you are outside of these countries, you will have to obtain this package
- * elsewhere.
- *
- */
-
-
-unsigned char sapphire::keyrand(int limit,
- unsigned char *user_key,
- unsigned char keysize,
- unsigned char *rsum,
- unsigned *keypos)
- {
- return keysize;
- }
-
-void sapphire::initialize(unsigned char *key, unsigned char keysize)
- {
- }
-
-void sapphire::hash_init(void)
- {
- }
-
-sapphire::sapphire(unsigned char *key, unsigned char keysize)
- {
- }
-
-void sapphire::burn(void)
- {
- }
-
-sapphire::~sapphire()
- {
- }
-
-unsigned char sapphire::encrypt(unsigned char b)
- {
- return b;
- }
-
-unsigned char sapphire::decrypt(unsigned char b)
- {
- return b;
- }
-
-void sapphire::hash_final(unsigned char *hash, // Destination
- unsigned char hashlength) // Size of hash.
- {
- }
-