summaryrefslogtreecommitdiff
path: root/src/frontend
diff options
context:
space:
mode:
Diffstat (limited to 'src/frontend')
-rw-r--r--src/frontend/X11/Makefile5
-rw-r--r--src/frontend/framework/femain.cpp11
-rw-r--r--src/frontend/im/hebrewmcim.cpp24
-rw-r--r--src/frontend/im/nullim.cpp9
-rw-r--r--src/frontend/im/swinputmeth.cpp21
-rw-r--r--src/frontend/swdisp.cpp20
-rw-r--r--src/frontend/swlog.cpp13
-rw-r--r--src/frontend/windoze/Makefile5
8 files changed, 53 insertions, 55 deletions
diff --git a/src/frontend/X11/Makefile b/src/frontend/X11/Makefile
deleted file mode 100644
index 1a2d00d..0000000
--- a/src/frontend/X11/Makefile
+++ /dev/null
@@ -1,5 +0,0 @@
-
-root := ../../..
-
-all:
- make -C ${root}
diff --git a/src/frontend/framework/femain.cpp b/src/frontend/framework/femain.cpp
index e6580cb..11bf565 100644
--- a/src/frontend/framework/femain.cpp
+++ b/src/frontend/framework/femain.cpp
@@ -1,5 +1,10 @@
-/*
- * Copyright 2009 CrossWire Bible Society (http://www.crosswire.org)
+/******************************************************************************
+ *
+ * femain.cpp - FEMain class definition
+ *
+ * $Id: femain.cpp 2833 2013-06-29 06:40:28Z chrislit $
+ *
+ * Copyright 1998-2013 CrossWire Bible Society (http://www.crosswire.org)
* CrossWire Bible Society
* P. O. Box 2528
* Tempe, AZ 85280-2528
@@ -23,7 +28,7 @@ FEMain::FEMain() {
FEMain::~FEMain() {
list <SWDisplay *>::iterator it;
- for (it = displays.begin(); it != displays.end(); it++)
+ for (it = displays.begin(); it != displays.end(); ++it)
delete *it;
}
diff --git a/src/frontend/im/hebrewmcim.cpp b/src/frontend/im/hebrewmcim.cpp
index c8bb5fa..839fcd7 100644
--- a/src/frontend/im/hebrewmcim.cpp
+++ b/src/frontend/im/hebrewmcim.cpp
@@ -1,14 +1,15 @@
-
-/**
- * Title: Keyboard mapping for Michigan-Claremont Hebrew input
- * Description:
- * Copyright: Copyright (c) 2001 CrossWire Bible Society under the terms of the GNU GPL
- * Company:
- * @author Troy A. Griffitts
- * @version 1.0
- */
-
-/*
+/******************************************************************************
+ *
+ * hebrewmcim.cpp - HebrewMCIM: Keyboard mapping for Michigan-Claremont
+ * Hebrew input
+ *
+ * $Id: hebrewmcim.cpp 2833 2013-06-29 06:40:28Z chrislit $
+ *
+ * Copyright 2001-2013 CrossWire Bible Society (http://www.crosswire.org)
+ * CrossWire Bible Society
+ * P. O. Box 2528
+ * Tempe, AZ 85280-2528
+ *
* This program is free software; you can redistribute it and/or modify it
* under the terms of the GNU General Public License as published by the
* Free Software Foundation version 2.
@@ -20,7 +21,6 @@
*
*/
-
#include <hebrewmcim.h>
HebrewMCIM::HebrewMCIM()
diff --git a/src/frontend/im/nullim.cpp b/src/frontend/im/nullim.cpp
index bceeb23..6fd9c0e 100644
--- a/src/frontend/im/nullim.cpp
+++ b/src/frontend/im/nullim.cpp
@@ -1,5 +1,10 @@
-/*
- * Copyright 2009 CrossWire Bible Society (http://www.crosswire.org)
+/******************************************************************************
+ *
+ * nullim.cpp - NullIM: Null keyboard mapping
+ *
+ * $Id: nullim.cpp 2833 2013-06-29 06:40:28Z chrislit $
+ *
+ * Copyright 2001-2013 CrossWire Bible Society (http://www.crosswire.org)
* CrossWire Bible Society
* P. O. Box 2528
* Tempe, AZ 85280-2528
diff --git a/src/frontend/im/swinputmeth.cpp b/src/frontend/im/swinputmeth.cpp
index 7ba60dd..49a7833 100644
--- a/src/frontend/im/swinputmeth.cpp
+++ b/src/frontend/im/swinputmeth.cpp
@@ -1,13 +1,14 @@
-/**
- * Title:
- * Description:
- * Copyright: Copyright (c) 2001 CrossWire Bible Society under the terms of the GNU GPL
- * Company:
- * @author Troy A. Griffitts
- * @version 1.0
- */
-
-/*
+/******************************************************************************
+ *
+ * swinputmeth.cpp - SWInputMethod: Input method base class
+ *
+ * $Id: swinputmeth.cpp 2833 2013-06-29 06:40:28Z chrislit $
+ *
+ * Copyright 2001-2013 CrossWire Bible Society (http://www.crosswire.org)
+ * CrossWire Bible Society
+ * P. O. Box 2528
+ * Tempe, AZ 85280-2528
+ *
* This program is free software; you can redistribute it and/or modify it
* under the terms of the GNU General Public License as published by the
* Free Software Foundation version 2.
diff --git a/src/frontend/swdisp.cpp b/src/frontend/swdisp.cpp
index bf46ff2..268fe7d 100644
--- a/src/frontend/swdisp.cpp
+++ b/src/frontend/swdisp.cpp
@@ -1,8 +1,12 @@
/******************************************************************************
- * swdisp.cpp - code for base class 'swdisp'. swdisp is the basis for all
- * types of displays (e.g. raw textout, curses, xwindow, etc.)
*
- * Copyright 2009 CrossWire Bible Society (http://www.crosswire.org)
+ * swdisp.cpp - code for base class 'SWDisplay'. SWDisplay is the
+ * basis for all types of displays (e.g. raw textout,
+ * curses, xwindow, etc.)
+ *
+ * $Id: swdisp.cpp 2833 2013-06-29 06:40:28Z chrislit $
+ *
+ * Copyright 1996-2013 CrossWire Bible Society (http://www.crosswire.org)
* CrossWire Bible Society
* P. O. Box 2528
* Tempe, AZ 85280-2528
@@ -19,9 +23,6 @@
*/
-#ifndef _WIN32_WCE
-#include <iostream>
-#endif
#include <swmodule.h>
#include <swdisp.h>
@@ -40,12 +41,5 @@ SWClass SWDisplay::classdef(classes);
* RET: error status
*/
-char SWDisplay::Display(SWModule &imodule)
-{
-#ifndef _WIN32_WCE
- std::cout << (const char *)imodule;
-#endif
- return 0;
-}
SWORD_NAMESPACE_END
diff --git a/src/frontend/swlog.cpp b/src/frontend/swlog.cpp
index 74b6bd4..7c05b47 100644
--- a/src/frontend/swlog.cpp
+++ b/src/frontend/swlog.cpp
@@ -1,5 +1,10 @@
-/*
- * Copyright 2009 CrossWire Bible Society (http://www.crosswire.org)
+/******************************************************************************
+ *
+ * swlog.cpp -
+ *
+ * $Id: swlog.cpp 2833 2013-06-29 06:40:28Z chrislit $
+ *
+ * Copyright 1997-2013 CrossWire Bible Society (http://www.crosswire.org)
* CrossWire Bible Society
* P. O. Box 2528
* Tempe, AZ 85280-2528
@@ -15,8 +20,6 @@
*
*/
-//---------------------------------------------------------------------------
-
#include <stdarg.h>
#include <stdio.h>
#include <iostream>
@@ -26,7 +29,7 @@
#include <unicode/ustream.h>
#endif
#include "swlog.h"
-//---------------------------------------------------------------------------
+
SWORD_NAMESPACE_START
diff --git a/src/frontend/windoze/Makefile b/src/frontend/windoze/Makefile
deleted file mode 100644
index 1a2d00d..0000000
--- a/src/frontend/windoze/Makefile
+++ /dev/null
@@ -1,5 +0,0 @@
-
-root := ../../..
-
-all:
- make -C ${root}