summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am17
1 files changed, 10 insertions, 7 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index afdf311..ad09283 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,16 +1,18 @@
AUTOMAKE_OPTIONS = 1.6
-INCLUDES = -I $(top_srcdir)/include
+AM_CPPFLAGS = -I $(top_srcdir)/include
if USE_INTERNAL_REGEX
-INCLUDES += -I$(top_srcdir)/include/internal/regex
+AM_CPPFLAGS += -I$(top_srcdir)/include/internal/regex
endif
LDADD = $(top_builddir)/lib/libsword.la
SUBDIRS = cppunit
-noinst_PROGRAMS = utf8norm ciphertest keytest mgrtest parsekey versekeytest vtreekeytest versemgrtest listtest casttest \
-modtest compnone complzss localetest introtest indextest configtest keycast \
-romantest testblocks filtertest rawldidxtest lextest swaptest \
- swbuftest xmltest webiftest striptest
+noinst_PROGRAMS = utf8norm ciphertest keytest mgrtest parsekey versekeytest \
+ vtreekeytest versemgrtest listtest casttest modtest \
+ compnone complzss localetest introtest indextest \
+ configtest keycast romantest testblocks filtertest \
+ rawldidxtest lextest swaptest swbuftest xmltest \
+ webiftest striptest osistest bibliotest
if HAVE_ICU
ICUPROG = icutest translittest tlitmgrtest
@@ -66,7 +68,8 @@ swbuftest_SOURCES = swbuftest.cpp
webiftest_SOURCES = webiftest.cpp
striptest_SOURCES = striptest.cpp
xmltest_SOURCES = xmltest.cpp
-
+osistest_SOURCES = osistest.cpp
+bibliotest_SOURCES = bibliotest.cpp
EXTRA_DIST =
include bcppmake/Makefile.am