summaryrefslogtreecommitdiff
path: root/tests/cppunit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/cppunit/Makefile.am')
-rw-r--r--tests/cppunit/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/cppunit/Makefile.am b/tests/cppunit/Makefile.am
new file mode 100644
index 0000000..2443be2
--- /dev/null
+++ b/tests/cppunit/Makefile.am
@@ -0,0 +1,16 @@
+LDADD = $(top_builddir)/lib/libsword.la
+
+# Rules for the test code (use `make check` to execute)
+if HAVE_CPPUNIT
+TESTS = LibSword
+else
+TESTS =
+endif
+check_PROGRAMS = $(TESTS)
+LibSword_SOURCES = main.cpp stringmgr_test.cpp swbuf_test.cpp url_test.cpp versekey_test.cpp
+LibSword_CXXFLAGS = $(CPPUNIT_CFLAGS) -I$(top_srcdir)/include
+LibSword_LDFLAGS = $(CPPUNIT_LIBS)
+
+swcppunitpdir = $(top_srcdir)/tests/cppunit
+
+#all: check