summaryrefslogtreecommitdiff
path: root/utilities/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'utilities/CMakeLists.txt')
-rw-r--r--utilities/CMakeLists.txt38
1 files changed, 7 insertions, 31 deletions
diff --git a/utilities/CMakeLists.txt b/utilities/CMakeLists.txt
index e7bd82d..bf53481 100644
--- a/utilities/CMakeLists.txt
+++ b/utilities/CMakeLists.txt
@@ -4,12 +4,12 @@
# The general assumption is that each of these utilities is built from
# a single source file, which shares its name with the utility itself (appended with .cpp),
# and then linked against the SWORD library.
-#
+#
# This list will be built and installed, if so chosen
#
# These are in alphbetical order now - please keep them that way
# if you edit this list in the future.
-#
+#
SET(install_UTILITIES
addld
emptyvss
@@ -35,14 +35,13 @@ ENDIF(WITH_ZLIB OR WITH_INTERNAL_ZLIB)
######################################################################
# These utilities will be built, but they will not be installed
-#
+#
# Again, I have gone to great lengths of travail to make this list
# alphabetical. If you add utilities to this list, please do so in a
# way that maintains this.
SET(noinstall_UTILITIES
addgb
addvs
- cipherraw
gbfidx
genbookutil
modwrite
@@ -54,7 +53,7 @@ SET(noinstall_UTILITIES
#####################################################################
# This will loop over both of the above utility lists and add build targets
# to the system for each one of them.
-#
+#
FOREACH(UTIL ${install_UTILITIES} ${noinstall_UTILITIES})
ADD_EXECUTABLE("${UTIL}" "${UTIL}.cpp")
@@ -68,7 +67,7 @@ ENDFOREACH(UTIL ${install_UTILITIES})
####################################################################
# Just to be difficult, we have a single C file that is a utility
# and, therefore, needs its own treatment.
-#
+#
ADD_EXECUTABLE(lexdump lexdump.c)
IF(BUILDING_SHARED)
@@ -85,7 +84,7 @@ ENDIF(BUILDING_SHARED)
# is limited to CMake files in this directory and below, so rather than
# replicate the above list in another place, we'll just handle our
# own install, since this whole directory is optional, anyway.
-#
+#
FOREACH(UTIL ${install_UTILITIES})
INSTALL(TARGETS ${UTIL}
RUNTIME DESTINATION "${BINDIR}"
@@ -93,27 +92,4 @@ FOREACH(UTIL ${install_UTILITIES})
)
ENDFOREACH(UTIL ${install_UTILITIES})
-####################################################################
-# And, of course, diatheke is a beast unto itself
-#
-# Let's go!
-#
-ADD_EXECUTABLE(diatheke
- diatheke/diatheke.cpp
- diatheke/corediatheke.cpp
- diatheke/diathekemgr.cpp
- diatheke/diafiltmgr.cpp
- diatheke/thmlcgi.cpp
- diatheke/gbfcgi.cpp
- diatheke/osiscgi.cpp
-)
-IF(BUILDING_SHARED)
- TARGET_LINK_LIBRARIES(diatheke sword)
-ELSE(BUILDING_SHARED)
- TARGET_LINK_LIBRARIES(diatheke sword_static)
-ENDIF(BUILDING_SHARED)
-INSTALL(TARGETS diatheke
- DESTINATION "${BINDIR}"
- COMPONENT utilities
-)
-
+ADD_SUBDIRECTORY("${CMAKE_CURRENT_SOURCE_DIR}/diatheke")