summaryrefslogtreecommitdiff
path: root/utilities/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'utilities/Makefile.am')
-rw-r--r--utilities/Makefile.am48
1 files changed, 38 insertions, 10 deletions
diff --git a/utilities/Makefile.am b/utilities/Makefile.am
index 4e4cd30..e516df0 100644
--- a/utilities/Makefile.am
+++ b/utilities/Makefile.am
@@ -1,22 +1,38 @@
-AUTOMAKE_OPTIONS = 1.5
+AUTOMAKE_OPTIONS = 1.6
+SUBDIRS = diatheke
INCLUDES = -I $(top_srcdir)/include
-LDADD = -L$(top_builddir)/lib -lsword
+LDADD = $(top_builddir)/lib/libsword.la
noinst_PROGRAMS = cipherraw ciphertest ciphertest2 lexdump mkfastmod \
-mod2vpl vpl2mod stepdump step2vpl mod2zmod modwrite addvs addld emptyvss \
-txt2sword addgb imp2gbs imp2ld imp2vs thml2gbs
+stepdump step2vpl gbfidx modwrite addvs emptyvss \
+txt2sword addgb imp2gbs mod2imp thml2gbs xml2gbs
+
+bin_PROGRAMS = mod2imp mod2osis osis2mod vs2osisref mod2vpl \
+ vpl2mod imp2vs installmgr
+
+if INSTALLMGR
+IMGRPROG =
+else
+IMGRPROG =
+endif
+
if ICU
-ICUPROG = normcode
+ICUPROG =
else
ICUPROG =
endif
+if ZLIB
+ZLIBPROG = mod2zmod addld imp2ld
+else
+ZLIBPROG =
+endif
+
noinst_PROGRAMS += $(ICUPROG)
+bin_PROGRAMS += $(ZLIBPROG) $(IMGRPROG)
if ICU
-normcode_SOURCES = normcode.cpp
-normcode_LDADD = -licui18n -licuuc
endif
cipherraw_SOURCES = cipherraw.cpp
@@ -29,14 +45,26 @@ mod2vpl_SOURCES = mod2vpl.cpp
vpl2mod_SOURCES = vpl2mod.cpp
stepdump_SOURCES = stepdump.cpp
step2vpl_SOURCES = step2vpl.cpp
-mod2zmod_SOURCES = mod2zmod.cpp
+gbfidx_SOURCES = gbfidx.cpp
modwrite_SOURCES = modwrite.cpp
addvs_SOURCES = addvs.cpp
-addld_SOURCES = addld.cpp
emptyvss_SOURCES = emptyvss.cpp
txt2sword_SOURCES = txt2sword.cpp
addgb_SOURCES = addgb.cpp
imp2gbs_SOURCES = imp2gbs.cpp
-imp2ld_SOURCES = imp2ld.cpp
imp2vs_SOURCES = imp2vs.cpp
+mod2imp_SOURCES = mod2imp.cpp
thml2gbs_SOURCES = thml2gbs.cpp
+mod2osis_SOURCES = mod2osis.cpp
+xml2gbs_SOURCES = xml2gbs.cpp
+osis2mod_SOURCES = osis2mod.cpp
+vs2osisref_SOURCES = vs2osisref.cpp
+
+installmgr_SOURCES = installmgr.cpp
+#installmgr_LDADD = -lcurl $(CURL_LIBS) $(LDADD)
+
+if ZLIB
+mod2zmod_SOURCES = mod2zmod.cpp
+addld_SOURCES = addld.cpp
+imp2ld_SOURCES = imp2ld.cpp
+endif