summaryrefslogtreecommitdiff
path: root/utilities/diatheke/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'utilities/diatheke/Makefile.am')
-rw-r--r--utilities/diatheke/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/utilities/diatheke/Makefile.am b/utilities/diatheke/Makefile.am
new file mode 100644
index 0000000..51a30c6
--- /dev/null
+++ b/utilities/diatheke/Makefile.am
@@ -0,0 +1,24 @@
+AUTOMAKE_OPTIONS = 1.6
+
+INCLUDES = -I$(top_srcdir)/include
+
+bin_PROGRAMS = diatheke
+
+diatheke_SOURCES = diatheke.cpp corediatheke.cpp diathekemgr.cpp \
+ diafiltmgr.cpp thmlcgi.cpp gbfcgi.cpp osiscgi.cpp
+
+if ICU
+iculibs = -licui18n -licuuc
+endif
+
+if USELUCENE
+lucenelibs = -lclucene
+endif
+
+diatheke_LDADD = $(top_builddir)/lib/libsword.la \
+ $(iculibs) $(lucenelibs)
+
+noinst_HEADERS = corediatheke.h diafiltmgr.h diathekemgr.h gbfcgi.h thmlcgi.h \
+ osiscgi.h
+
+include cgi/Makefile.am