summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2014-10-21 11:21:13 -0400
committerJoey Hess <joey@kitenet.net>2014-10-21 11:21:13 -0400
commit28b5499e656da835c3c7491f6489cba158dae6cc (patch)
tree9340e395e4bb953e521f17dcb54baaf95deba803
parent1fa91e1d8f100e01937440c1469123e006e8fe43 (diff)
Gnome only works on i386 and amd64, so default to xfce on other arches. Closes: #765839 Thanks, Adam Borowski for testing.HEADdebian/3.29master
-rw-r--r--debian/changelog7
-rw-r--r--default_desktop9
2 files changed, 13 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index e5b72c34..38ee52e6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+tasksel (3.29) unstable; urgency=high
+
+ * Gnome only works on i386 and amd64, so default to xfce on other arches.
+ Closes: #765839 Thanks, Adam Borowski for testing.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 21 Oct 2014 11:21:06 -0400
+
tasksel (3.28) unstable; urgency=medium
* Display cinnamon and lxde tasks. However, this increases the total
diff --git a/default_desktop b/default_desktop
index 12a08f3c..9b840ee1 100644
--- a/default_desktop
+++ b/default_desktop
@@ -6,8 +6,11 @@
default_desktop_for_arch() {
case "$1" in
- kfreebsd-*) echo xfce ;;
- hurd-*) echo xfce ;;
- *) echo gnome ;;
+ i386) echo gnome ;;
+ amd64) echo gnome ;;
+ # gnome only works on linux,
+ # and only on arches with 3d hardware
+ # or llvmpipe. See #765839.
+ *) echo xfce ;;
esac
}