summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Preud'homme <robotux@celest.fr>2013-02-17 23:39:08 +0100
committerThomas Preud'homme <robotux@celest.fr>2018-02-24 16:46:19 +0000
commitdc6b796293da8f4f411e369f241b41ce1c49ee77 (patch)
tree683b1c98c319fecfb0d70d9db9f5bb99df27ad69
parent557d51707f31b75321fc25d80e5bf249895d171c (diff)
Disable stack protector in runtime library
tcc fails to run when compiled by itself and its runtime library was built with any variant of -fstack-protector. This is why test3 fails when libtcc1.a is build with -fstack-protector. Origin: vendor Forwarded: no Last-Update: 2018-02-24
-rw-r--r--lib/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Makefile b/lib/Makefile
index 0c1ec54..be25e88 100644
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -20,6 +20,7 @@ XCFG = $(or $(findstring -win,$T),-unx)
# in order to use gcc, tyoe: make <target>-libtcc1-usegcc=yes
arm-libtcc1-usegcc ?= no
+CFLAGS:=$(CFLAGS) -fno-stack-protector
ifeq "$($(T)-libtcc1-usegcc)" "yes"
XCC = $(CC)
XAR = $(AR)