summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Preud'homme <robotux@celest.fr>2013-02-17 23:39:08 +0100
committerThomas Preud'homme <robotux@celest.fr>2018-02-24 00:17:40 +0000
commit09f0871781d6462279d3ea97db05b0cc4d77d4d2 (patch)
tree40bcb71d64a878e04c15aba7eef13fa445e33e65
parent557d51707f31b75321fc25d80e5bf249895d171c (diff)
Disable stack protector in runtime library
tcc fails to run when compiled by itself and its runtime library was built with any variant of -fstack-protector. This is why test3 fails when libtcc1.a is build with -fstack-protector. Origin: vendor Forwarded: no Last-Update: 2018-02-24
-rw-r--r--lib/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/Makefile b/lib/Makefile
index 0c1ec54..be0e648 100644
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -20,6 +20,7 @@ XCFG = $(or $(findstring -win,$T),-unx)
# in order to use gcc, tyoe: make <target>-libtcc1-usegcc=yes
arm-libtcc1-usegcc ?= no
+CFLAGS:=$(CFLAGS) -fstack-protector
ifeq "$($(T)-libtcc1-usegcc)" "yes"
XCC = $(CC)
XAR = $(AR)