summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Preud'homme <robotux@celest.fr>2018-03-14 00:29:01 +0000
committerThomas Preud'homme <robotux@celest.fr>2018-03-14 00:30:58 +0000
commitc8cf6a05e0fe6384415fe31734aa6c7732ff3acd (patch)
tree4b1a28c73741eec0b59f2178bd771d46c3f20c92
parent55d5a5b55d0db20d9c5c7f99ab90130ce93f5408 (diff)
Fix retrieval of DEB_HOST_MULTIARCH for i386 host.
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/rules2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 2985dc3..9b08643 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ tcc (0.9.27-7) UNRELEASED; urgency=medium
* debian/rules:
+ Set host CPU based on Debian architecture to ensure reproducible build.
+ + Fix retrieval of DEB_HOST_MULTIARCH for i386 host.
-- Thomas Preud'homme <robotux@debian.org> Tue, 13 Mar 2018 21:41:50 +0000
diff --git a/debian/rules b/debian/rules
index ea32dea..674cf06 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,7 @@
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
ifeq (amd64,$(DEB_HOST_ARCH))
- DEB_I386_MULTIARCH:=$(shell dpkg-architecture --host-arch i386 \
+ DEB_I386_MULTIARCH:=$(shell CC=true dpkg-architecture -f --host-arch i386 \
-q DEB_HOST_MULTIARCH)
DEF_I386='-DCONFIG_TRIPLET="\"$(DEB_I386_MULTIARCH)\"" -DTCC_TARGET_I386'
endif