summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMatteo Cypriani <mcy@lm7.fr>2014-10-07 11:34:49 -0400
committerMatteo Cypriani <mcy@lm7.fr>2014-10-07 11:34:49 -0400
commitd849ea4f5d5d9c9c45ac477f8f8b34e5302a579a (patch)
treed0a67e1ce7a255c45602a9f55e64fa048e73ae2b /debian
parent9462e385b94d6b7f1f4014c4aa3cdf01f8dbc4b3 (diff)
update debian/patches directory
Diffstat (limited to 'debian')
-rw-r--r--debian/.git-dpm2
-rw-r--r--debian/patches/0001-Disable-floating-point-test-for-ARM-soft-float.patch42
-rw-r--r--debian/patches/0002-Disable-BTESTS-completely.patch4
3 files changed, 34 insertions, 14 deletions
diff --git a/debian/.git-dpm b/debian/.git-dpm
index 44b24d6..98b5865 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,5 +1,5 @@
# see git-dpm(1) from git-dpm package
-6c593a4abf9f029663f7c4fad779e8085332d6fc
+c6077e0547a9a0c3bfd005163beb4474dc32bb05
c6077e0547a9a0c3bfd005163beb4474dc32bb05
2946895a376add9d940bdbe4391e97cb846d26d1
2946895a376add9d940bdbe4391e97cb846d26d1
diff --git a/debian/patches/0001-Disable-floating-point-test-for-ARM-soft-float.patch b/debian/patches/0001-Disable-floating-point-test-for-ARM-soft-float.patch
index 32ca872..074e0cc 100644
--- a/debian/patches/0001-Disable-floating-point-test-for-ARM-soft-float.patch
+++ b/debian/patches/0001-Disable-floating-point-test-for-ARM-soft-float.patch
@@ -1,4 +1,4 @@
-From 5b58c3786a9ae3b38c2139b394fc9e9b8c49a853 Mon Sep 17 00:00:00 2001
+From 17f01d0d80c45bfc1dda7aa4e9ee7d7d257c9000 Mon Sep 17 00:00:00 2001
From: Matteo Cypriani <mcy@lm7.fr>
Date: Fri, 5 Sep 2014 23:22:56 -0400
Subject: Disable floating-point test for ARM soft-float
@@ -9,12 +9,36 @@ displays a warning to warn ARM users about this limitation.
Origin: vendor
Forwarded: no
-Last-Update: 2014-09-07
+Last-Update: 2014-10-07
---
+ tests/Makefile | 10 ++++++++--
tests/tcctest.c | 2 ++
- tests/tests2/Makefile | 13 +++++++++++--
- 2 files changed, 13 insertions(+), 2 deletions(-)
+ tests/tests2/Makefile | 9 +++++++--
+ 3 files changed, 17 insertions(+), 4 deletions(-)
+diff --git a/tests/Makefile b/tests/Makefile
+index e6c5660..f2813ba 100644
+--- a/tests/Makefile
++++ b/tests/Makefile
+@@ -214,10 +214,16 @@ abitest-cc$(EXESUF): abitest.c $(top_builddir)/$(LIBTCC)
+ abitest-tcc$(EXESUF): abitest.c libtcc.c
+ $(TCC) -o $@ $^ $(CPPFLAGS) $(CFLAGS) $(NATIVE_DEFINES) -DONE_SOURCE $(LIBS) $(LDFLAGS) -I$(top_srcdir)
+
+-abitest: abitest-cc$(EXESUF) abitest-tcc$(EXESUF)
++ABITESTS := abitest-cc$(EXESUF)
++ifneq ($(CONFIG_arm_eabi),yes) # not ARM soft-float
++ ABITESTS += abitest-tcc$(EXESUF)
++endif
++
++abitest: $(ABITESTS)
+ @echo ------------ $@ ------------
+ ./abitest-cc$(EXESUF) lib_path=.. include="$(top_srcdir)/include"
+- ./abitest-tcc$(EXESUF) lib_path=.. include="$(top_srcdir)/include"
++ if [ $(CONFIG_arm_eabi) != "yes" ]; then \
++ ./abitest-tcc$(EXESUF) lib_path=.. include="$(top_srcdir)/include"; fi
+
+ vla_test$(EXESUF): vla_test.c
+ $(TCC) -o $@ $^ $(CPPFLAGS) $(CFLAGS)
diff --git a/tests/tcctest.c b/tests/tcctest.c
index cc8ffd8..78bb785 100644
--- a/tests/tcctest.c
@@ -36,10 +60,10 @@ index cc8ffd8..78bb785 100644
int fib(int n)
diff --git a/tests/tests2/Makefile b/tests/tests2/Makefile
-index 66d2f5a..1068105 100644
+index 66d2f5a..4da68d9 100644
--- a/tests/tests2/Makefile
+++ b/tests/tests2/Makefile
-@@ -41,8 +41,17 @@ TESTS = \
+@@ -41,8 +41,13 @@ TESTS = \
18_include.test \
19_pointer_arithmetic.test \
20_pointer_comparison.test \
@@ -47,12 +71,8 @@ index 66d2f5a..1068105 100644
- 22_floating_point.test \
+ 21_char_array.test
+
-+ifeq ($(findstring -DTCC_ARM_EABI,$(NATIVE_DEFINES)),)
++ifneq ($(CONFIG_arm_eabi),yes) # not ARM soft-float
+ TESTS += 22_floating_point.test
-+else
-+ ifneq ($(findstring -DTCC_ARM_HARDFLOAT,$(NATIVE_DEFINES)),)
-+ TESTS += 22_floating_point.test
-+ endif
+endif
+
+TESTS += \
diff --git a/debian/patches/0002-Disable-BTESTS-completely.patch b/debian/patches/0002-Disable-BTESTS-completely.patch
index a03bd0d..9b42cb1 100644
--- a/debian/patches/0002-Disable-BTESTS-completely.patch
+++ b/debian/patches/0002-Disable-BTESTS-completely.patch
@@ -1,4 +1,4 @@
-From 6c593a4abf9f029663f7c4fad779e8085332d6fc Mon Sep 17 00:00:00 2001
+From c6077e0547a9a0c3bfd005163beb4474dc32bb05 Mon Sep 17 00:00:00 2001
From: Matteo Cypriani <mcy@lm7.fr>
Date: Sun, 7 Sep 2014 12:32:27 -0400
Subject: Disable BTESTS completely
@@ -13,7 +13,7 @@ Last-Update: 2014-09-07
1 file changed, 1 deletion(-)
diff --git a/tests/Makefile b/tests/Makefile
-index e6c5660..77c8481 100644
+index f2813ba..6b86c9c 100644
--- a/tests/Makefile
+++ b/tests/Makefile
@@ -17,7 +17,6 @@ TESTS = \