summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBardur Arantsson <bardur@scientician.net>2012-04-01 18:44:51 +0200
committerBardur Arantsson <bardur@scientician.net>2012-04-02 19:16:51 +0200
commita6c3015b17efb98c8fb595f7be237c5a5cb52ce3 (patch)
tree253a842bc4c630321d19867382d931fc6a1536c9
parent2af4f72a86d70703bbb55515cb468fba6240fda7 (diff)
Remove unused USE_WINSOCK and USE_UNIXSOCK compile-time flags
-rw-r--r--CMakeLists.txt7
-rw-r--r--src/main-win.c8
2 files changed, 0 insertions, 15 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a4bc662..660008e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,13 +17,6 @@ ENDIF()
ADD_DEFINITIONS(-DSUPPORT_GAMMA)
ADD_DEFINITIONS(-DUSE_PRECISE_CMOVIE)
-# Which socket implementation are we using?
-IF(WIN32)
-ADD_DEFINITIONS(-DUSE_WINSOCK)
-ELSE()
-ADD_DEFINITIONS(-DUSE_UNIXSOCK)
-ENDIF()
-
#
# X11 support (OPTIONAL)
#
diff --git a/src/main-win.c b/src/main-win.c
index 420ac858..7cbebcf2 100644
--- a/src/main-win.c
+++ b/src/main-win.c
@@ -232,14 +232,6 @@
*/
#include <windows.h>
-/*
- * For IRC stuff
- */
-#ifdef USE_WINSOCK
-#define ZSOCK_TIMER_ID 1
-#define ZSOCK_TIMER_RATE 50
-#endif
-
/*
* Exclude parts of MMSYSTEM.H that are not needed