summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBardur Arantsson <bardur@scientician.net>2015-02-23 09:11:57 +0100
committerBardur Arantsson <bardur@scientician.net>2015-02-23 09:11:57 +0100
commit6047df25fef41fe621a8a9ef5915874516bdec7a (patch)
treea9d65e9f773beba49b3e9efe140faf812ef7881b
parent52c63722c444a25059f52c8c5d4b364f56bffb28 (diff)
Add ASAN and UBSAN options by default
-rw-r--r--CMakeLists.txt2
-rw-r--r--RELEASE.txt1
2 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0ed83915..b52470d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@ INCLUDE(FindPkgConfig)
#
# Basic common compiler flags.
#
-SET(COMMON_COMPILER_FLAGS "-pipe -Wall -Wno-unused-value")
+SET(COMMON_COMPILER_FLAGS "-pipe -Wall -Wno-unused-value -fsanitize=undefined -fsanitize=address")
#
# GCC/G++ flags
diff --git a/RELEASE.txt b/RELEASE.txt
index 2646fc0e..ab082315 100644
--- a/RELEASE.txt
+++ b/RELEASE.txt
@@ -5,3 +5,4 @@ Release Checklist:
* Update changes.txt
* Update IS_CVS in defines.h before tagging; undo post-tagging.
* Check that system-wide installation succeeds.
+* Disable C/C++ compiler sanitization options