summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2020-05-27 16:50:54 -0700
committerManoj Srivastava <srivasta@debian.org>2020-05-27 20:16:24 -0700
commit7661a944652f6e71c93a31b2b7f7a4136e360f30 (patch)
tree9658bdeb0706fdaf30a8fd59662949c298f2626d
parent2c93afb0089a37de798da8d23824a84846ab7d7c (diff)
Closes: #961367 Signed-off-by: Manoj Srivastava <srivasta@debian.org>
-rw-r--r--debian/changelog9
-rw-r--r--debian/control3
-rw-r--r--src/CMakeLists.txt6
3 files changed, 13 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index f3f9d4f3..f9a30f2b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+tome (2.41-ah~0.git.20200131-1) unstable; urgency=medium
+
+ * New ipstream git snapshot (sync to head)
+ * Bug fix: "tome FTBFS on 32bit: invalid conversion from ‘uint32_t*’
+ {aka ‘unsigned int*’} to ‘u32b*’ {aka ‘long unsigned int*’}", thanks
+ to Adrian Bunk (Closes: #961367).
+
+ -- Manoj Srivastava <srivasta@debian.org> Wed, 27 May 2020 16:50:33 -0700
+
tome (2.4.0-ah-1) unstable; urgency=medium
* New upstream version
diff --git a/debian/control b/debian/control
index bc75f59c..ed88d4ad 100644
--- a/debian/control
+++ b/debian/control
@@ -7,8 +7,7 @@ Maintainer: Manoj Srivastava <srivasta@debian.org>
Homepage: https://github.com/tome2/tome2
Build-Depends: debhelper-compat (= 12), libjansson-dev, cmake,
libncurses5-dev | libncurses-dev | ncurses-dev, libboost-all-dev,
- libsdl-image1.2-dev, libsdl-ttf2.0-dev, libx11-dev, libgtk2.0-dev,
- dpkg-dev (>= 1.16.0)
+ libx11-dev, libgtk2.0-dev, dpkg-dev (>= 1.16.0)
XS-Autobuild: yes
Standards-Version: 4.3.0
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6c9ca9d6..2d5d5566 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -166,21 +166,21 @@ IF(X11_FOUND)
INCLUDE_DIRECTORIES(${X11_INCLUDE_DIR})
ADD_EXECUTABLE(tome-x11 main-x11.cc)
TARGET_LINK_LIBRARIES(tome-x11 game_main game squelch ${LIBS} ${X11_LIBRARIES})
- INSTALL(TARGETS tome-x11 RUNTIME DESTINATION bin)
+ INSTALL(TARGETS tome-x11 RUNTIME DESTINATION games)
ENDIF()
IF(CURSES_FOUND)
INCLUDE_DIRECTORIES(${CURSES_INCLUDE_DIR})
ADD_EXECUTABLE(tome-gcu main-gcu.cc)
TARGET_LINK_LIBRARIES(tome-gcu game_main game squelch ${LIBS} ${CURSES_LIBRARIES})
- INSTALL(TARGETS tome-gcu RUNTIME DESTINATION bin)
+ INSTALL(TARGETS tome-gcu RUNTIME DESTINATION games)
ENDIF()
IF(GTK2_FOUND)
INCLUDE_DIRECTORIES(${GTK2_INCLUDE_DIRS})
ADD_EXECUTABLE(tome-gtk2 main-gtk2.cc)
TARGET_LINK_LIBRARIES(tome-gtk2 game_main game squelch ${LIBS} ${GTK2_LIBRARIES})
- INSTALL(TARGETS tome-gtk2 RUNTIME DESTINATION bin)
+ INSTALL(TARGETS tome-gtk2 RUNTIME DESTINATION games)
ENDIF()
# test harness executable