summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBardur Arantsson <bardur@scientician.net>2015-04-14 06:39:21 +0200
committerBardur Arantsson <bardur@scientician.net>2015-04-14 06:39:21 +0200
commit25d4950957f86d0c31f77c2a0b39d918cad51a5f (patch)
treed78d3d7c4506bb7372109203a2a7bb001e6f301b /CMakeLists.txt
parent011593acd80550281f6b0702546dd9760805c4e6 (diff)
Bump Boost to 1.54.x and add boost::filesystem dependency
As fas as I can tell, 1.54.x should be available in the latest Ubuntu LTS, so it hopefully shouldn't be a problem.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b52470d9..be48e6ee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -56,11 +56,12 @@ ENDIF()
#
# BOOST
#
-FIND_PACKAGE(Boost 1.48.0)
+FIND_PACKAGE(Boost 1.54.0 REQUIRED COMPONENTS system filesystem)
IF(Boost_FOUND)
+ ADD_DEFINITIONS(-DBOOST_FILESYSTEM_NO_DEPRECATED)
INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
- SET(LIBS ${LIBS} ${Boost_LIBRARIES})
+ SET(LIBS ${LIBS} ${Boost_LIBRARIES} ${Boost_SYSTEM_LIBRARY} ${Boost_FILESYSTEM_LIBRARY})
ENDIF()
#