summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBardur Arantsson <bardur@scientician.net>2010-01-17 09:00:55 +0100
committerBardur Arantsson <bardur@scientician.net>2010-01-17 10:01:50 +0100
commit7099a084c7a7438a5f6ce34a2aca7ee5fa62ae7e (patch)
treed6450cf4411db52aed97309577448160aaa01cdc /CMakeLists.txt
parentf643e0f1a98f06dee9e0bd7973e4549deae9ddb9 (diff)
Add an "install" target.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 147e39b2..a6b9aba2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,9 @@
PROJECT (tome2)
CMAKE_MINIMUM_REQUIRED (VERSION 2.6)
+# We want a readable feature summary.
+INCLUDE(FeatureSummary)
+
# Default flags.
IF(CMAKE_COMPILER_IS_GNUCC)
# Let's set sensible options.
@@ -62,5 +65,19 @@ IF(CURSES_FOUND)
SET(LIBS ${LIBS} ${CURSES_LIBRARIES})
ENDIF()
+#
+# Set the path for loading the library bits.
+#
+IF(SYSTEM_INSTALL)
+ SET(DEFAULT_PATH "${CMAKE_INSTALL_PREFIX}/lib/tome")
+ELSE()
+ SET(DEFAULT_PATH "./lib")
+ENDIF()
+ADD_DEFINITIONS(-DDEFAULT_PATH="${DEFAULT_PATH}")
+
+# Print out a summary of features.
+PRINT_ENABLED_FEATURES()
+
# Add the source subdirectory.
ADD_SUBDIRECTORY (src)
+ADD_SUBDIRECTORY (lib)