summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Klose <doko@debian.org>2017-09-13 13:25:47 -0700
committerMatthias Klose <doko@debian.org>2017-09-13 13:25:47 -0700
commitabc3836ffbf6083c2572f5c8622e4926c71ebc9c (patch)
tree91e54a6407b17e02e410dbe9a6335b2c4d74c245 /CMakeLists.txt
parent17afaf664eeca4f972356e65a619bb42d5bd4283 (diff)
tome (2.4~0.git.2015.12.29-1.2) unstable; urgency=medium
* Non-maintainer upload. [ Colin Watson ] * Only build with -fsanitize=undefined -fsanitize=address on architectures that support these. [ Bhavani Shankar ] * Match variable boolean type in z-rand.cc to fix compilation on 32 bit archs. Thanks to Andreas Beckmann from debian for the report. Closes: #843984. [dgit import package tome 2.4~0.git.2015.12.29-1.2]
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9519785a..b5f24419 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@ INCLUDE(FindPkgConfig)
#
# Basic common compiler flags.
#
-SET(COMMON_COMPILER_FLAGS "-pipe -Wall -Wno-unused-value -fsanitize=undefined -fsanitize=address")
+SET(COMMON_COMPILER_FLAGS "-pipe -Wall -Wno-unused-value")
#
# GCC/G++ flags
@@ -143,7 +143,7 @@ endif(WIN32)
# Set the path for loading the library bits.
#
IF(SYSTEM_INSTALL)
- SET(DEFAULT_PATH "${CMAKE_INSTALL_PREFIX}/lib/tome")
+ SET(DEFAULT_PATH "/var/games/tome")
ELSE()
SET(DEFAULT_PATH "./lib")
ENDIF()