summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBardur Arantsson <bardur@scientician.net>2016-10-05 18:45:07 +0200
committerBardur Arantsson <bardur@scientician.net>2016-10-05 18:45:07 +0200
commit9224ae637c06dc1a470ee90a19628c004f1ff35b (patch)
tree948baa778f9dc2a908a18083462746ab42dc55a1 /CMakeLists.txt
parent3d617a0320d126715173681cb10ce7f6b80daff9 (diff)
Add a few more compiler warning flags
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1c805161..6b804357 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@ INCLUDE(FindPkgConfig)
#
# Basic common compiler flags.
#
-SET(COMMON_COMPILER_FLAGS "-pipe -Wall -Wno-unused-value -fsanitize=undefined -fsanitize=address")
+SET(COMMON_COMPILER_FLAGS "-pipe -Wall -Wextra -Wno-unused-value -Wno-unused-parameter -fsanitize=undefined -fsanitize=address")
#
# GCC/G++ flags