summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
authorBardur Arantsson <bardur@scientician.net>2010-01-17 09:00:55 +0100
committerBardur Arantsson <bardur@scientician.net>2010-01-17 10:01:50 +0100
commit7099a084c7a7438a5f6ce34a2aca7ee5fa62ae7e (patch)
treed6450cf4411db52aed97309577448160aaa01cdc /lib
parentf643e0f1a98f06dee9e0bd7973e4549deae9ddb9 (diff)
Add an "install" target.
Diffstat (limited to 'lib')
-rw-r--r--lib/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
new file mode 100644
index 00000000..acb87b25
--- /dev/null
+++ b/lib/CMakeLists.txt
@@ -0,0 +1,26 @@
+INSTALL(FILES
+ module.lua
+ DESTINATION ${DEFAULT_PATH}
+)
+INSTALL(DIRECTORY
+ apex
+ cmov
+ core
+ data
+ dngn
+ edit
+ file
+ help
+ info
+ mods
+ note
+ plot
+ pref
+ save
+ scpt
+ user
+ xtra
+ DESTINATION ${DEFAULT_PATH}
+ PATTERN "*.raw" EXCLUDE
+ PATTERN "delete.me" EXCLUDE
+ )