summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorBardur Arantsson <bardur@scientician.net>2015-02-23 09:11:56 +0100
committerBardur Arantsson <bardur@scientician.net>2015-02-23 09:11:56 +0100
commitc63c783ef4634f5715a5aafb4397c9b8bb844358 (patch)
treec835ee6a5cd27be3584f09e78a1bda95f371d9ed /src/CMakeLists.txt
parent30bccfa32e7e68c8d18a0364441ff756075415e7 (diff)
Use explicit list of test files to avoid "forgot-to-regenerate"
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a834095b..24074cb9 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -37,7 +37,10 @@ SET(SRCS_COMMON
SET(SRCS_PROGRAM main-gcu.c main-x11.c main-sdl.c main-gtk2.c main.c)
# Sources (TEST)
-FILE(GLOB SRCS_TESTS ../tests/**.cc)
+SET(SRCS_TESTS
+ ../tests/get_level_device.cc
+ ../tests/lua_get_level.cc
+ ../tests/harness.cc)
# Need a few additional source files for Windows.
if(WIN32)