summaryrefslogtreecommitdiff
path: root/src/files.cc
diff options
context:
space:
mode:
authorBardur Arantsson <bardur@scientician.net>2015-02-23 09:11:58 +0100
committerBardur Arantsson <bardur@scientician.net>2015-02-23 09:11:58 +0100
commit3bfa6a0e2cba6b4fc8f53dac1e987c95fe7ed93c (patch)
tree634ca5f034290d081f240cfb4f75b33ffa7409d5 /src/files.cc
parent3f59d3d407cd743f4e4b27791c4fe13785f8669d (diff)
Remove c_head, c_name, c_text
Diffstat (limited to 'src/files.cc')
-rw-r--r--src/files.cc15
1 files changed, 9 insertions, 6 deletions
diff --git a/src/files.cc b/src/files.cc
index 396883f5..005b4ed8 100644
--- a/src/files.cc
+++ b/src/files.cc
@@ -869,7 +869,7 @@ static cptr process_pref_file_expr(char **sp, char *fp)
/* Class */
else if (streq(b + 1, "CLASS"))
{
- v = spp_ptr->title + c_name;
+ v = spp_ptr->title;
}
/* Player */
@@ -2182,7 +2182,7 @@ void display_player(int mode)
c_put_str(TERM_L_BLUE, sp_ptr->title, 3, 9);
sprintf(buf, "%s", get_player_race_name(p_ptr->prace, p_ptr->pracem));
c_put_str(TERM_L_BLUE, buf, 4, 9);
- c_put_str(TERM_L_BLUE, spp_ptr->title + c_name, 5, 9);
+ c_put_str(TERM_L_BLUE, spp_ptr->title, 5, 9);
c_put_str(TERM_L_BLUE, r_ptr->name, 6, 9);
c_put_str(TERM_L_BLUE, deity_info[p_ptr->pgod].name, 7, 9);
@@ -4436,7 +4436,7 @@ static void print_tomb(void)
/* Normal */
else
{
- p = cp_ptr->titles[(p_ptr->lev - 1) / 5] + c_text;
+ p = cp_ptr->titles[(p_ptr->lev - 1) / 5];
}
center_string(buf, player_name);
@@ -4449,7 +4449,7 @@ static void print_tomb(void)
put_str(buf, 8, 11);
- center_string(buf, spp_ptr->title + c_name);
+ center_string(buf, spp_ptr->title);
put_str(buf, 10, 11);
(void)sprintf(tmp, "Level: %d", (int)p_ptr->lev);
@@ -4764,8 +4764,11 @@ static void display_scores_aux(int highscore_fd, int from, int to, int note, hig
/* Dump some info */
sprintf(out_val, "%3d.%9s %s the %s %s, Level %d",
- place, the_score.pts, the_score.who,
- get_player_race_name(pr, ps), class_info[pc].spec[pcs].title + c_name,
+ place,
+ the_score.pts,
+ the_score.who,
+ get_player_race_name(pr, ps),
+ class_info[pc].spec[pcs].title,
clev);
/* Append a "maximum level" */