summaryrefslogtreecommitdiff
path: root/src/spell_type_fwd.hpp
diff options
context:
space:
mode:
authorManoj Srivastava <srivasta@debian.org>2016-01-27 13:11:31 -0800
committerManoj Srivastava <srivasta@debian.org>2016-01-27 13:11:31 -0800
commit02819db3483514d49df7ec3f7e372b5aeb831466 (patch)
tree6a86adac74beac293bc688dafcfa1709a6476901 /src/spell_type_fwd.hpp
parent2a61dffe127e22c1aaf955db6f085ac2eefbebba (diff)
parent6f6de67c70fd98815088ce49f046f48f88ea35bd (diff)
Merge branch 'upstream'
Signed-off-by: Manoj Srivastava <srivasta@debian.org> # Conflicts: # src/CMakeLists.txt # src/config.h # src/lua/llimits.h
Diffstat (limited to 'src/spell_type_fwd.hpp')
-rw-r--r--src/spell_type_fwd.hpp16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/spell_type_fwd.hpp b/src/spell_type_fwd.hpp
new file mode 100644
index 00000000..a3b27d27
--- /dev/null
+++ b/src/spell_type_fwd.hpp
@@ -0,0 +1,16 @@
+#pragma once
+
+/*
+ * Spell effect function result
+ */
+typedef enum {
+ NO_CAST, /* Spell not cast; user aborted */
+ CAST_OBVIOUS, /* Cast; caster discovers effect (devices) */
+ CAST_HIDDEN /* Cast; caster does NOT discover effect (devices) */
+} casting_result;
+
+/*
+ * Forward declaration of the spell_type
+ */
+typedef struct spell_type spell_type;
+struct spell_type;