summaryrefslogtreecommitdiff
path: root/src/xtra2.c
diff options
context:
space:
mode:
authorBardur Arantsson <bardur@scientician.net>2012-04-06 16:28:21 +0200
committerBardur Arantsson <bardur@scientician.net>2012-04-07 15:28:26 +0200
commitbf358f4520ea47059e02237892955edaa24c8be9 (patch)
tree4e35f0c2219163af4bdec7c38b7c25f65314a174 /src/xtra2.c
parente620b7e9e0b6a70f4c350c84a7c18ea2b523eab4 (diff)
Lua: Remove unused switch_class and switch_subclass
Diffstat (limited to 'src/xtra2.c')
-rw-r--r--src/xtra2.c18
1 files changed, 0 insertions, 18 deletions
diff --git a/src/xtra2.c b/src/xtra2.c
index 45a0caec..34a2a283 100644
--- a/src/xtra2.c
+++ b/src/xtra2.c
@@ -6066,24 +6066,6 @@ void corrupt_corrupted(void)
}
/*
- * Change to an other class
- */
-void switch_class(int sclass)
-{
- p_ptr->pclass = sclass;
- cp_ptr = &class_info[p_ptr->pclass];
-}
-
-/*
- * Change to an other subclass
- */
-void switch_subclass(int sclass)
-{
- p_ptr->pspec = sclass;
- spp_ptr = &class_info[p_ptr->pclass].spec[p_ptr->pspec];
-}
-
-/*
* Change to an other subrace
*/
void switch_subrace(int racem, bool_ copy_old)