summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorBardur Arantsson <bardur@scientician.net>2013-03-24 19:08:32 +0100
committerBardur Arantsson <bardur@scientician.net>2013-09-27 14:46:41 +0200
commit0a7cd1758c9e5f321f8652ada9b6637b352999ec (patch)
treeaeeb75d5af4f6637375760f8527c56cb46a301ea /src
parente4aad7f42f675137e877f2c8ca3dd8a0da2fc6aa (diff)
Split Nazgul quest from plots.c
Diffstat (limited to 'src')
-rw-r--r--src/CMakeLists.txt2
-rw-r--r--src/plots.c1
-rw-r--r--src/plots.h1
-rw-r--r--src/q_nazgul.c3
-rw-r--r--src/q_nazgul.h13
-rw-r--r--src/tables.c1
6 files changed, 17 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 17a0e0a8..2ffa3748 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -13,7 +13,7 @@ SET(SRCS
q_god.c q_library.c q_fireprof.c q_bounty.c q_thrain.c
q_narsil.c q_evil.c q_betwen.c q_haunted.c q_invas.c
q_nirna.c q_eol.c q_god.c q_dragons.c q_poison.c
- q_spider.c q_wolves.c q_shroom.c
+ q_spider.c q_wolves.c q_shroom.c q_nazgul.c
object1.c object2.c randart.c squeltch.cc traps.c
monster1.c monster2.c monster3.c
xtra1.c xtra2.c skills.c powers.c gods.c
diff --git a/src/plots.c b/src/plots.c
index 0b9b36fa..75370362 100644
--- a/src/plots.c
+++ b/src/plots.c
@@ -374,4 +374,3 @@ bool_ quest_null_hook(int q)
#include "q_hobbit.c"
#include "q_troll.c"
#include "q_wight.c"
-#include "q_nazgul.c"
diff --git a/src/plots.h b/src/plots.h
index df713fb9..1320e295 100644
--- a/src/plots.h
+++ b/src/plots.h
@@ -22,4 +22,3 @@ extern bool_ quest_thieves_init_hook(int q_idx);
extern bool_ quest_hobbit_init_hook(int q_idx);
extern bool_ quest_troll_init_hook(int q_idx);
extern bool_ quest_wight_init_hook(int q_idx);
-extern bool_ quest_nazgul_init_hook(int q_idx);
diff --git a/src/q_nazgul.c b/src/q_nazgul.c
index 66d3dc98..b386b70f 100644
--- a/src/q_nazgul.c
+++ b/src/q_nazgul.c
@@ -1,4 +1,5 @@
-#undef cquest
+#include "q_nazgul.h"
+
#define cquest (quest[QUEST_NAZGUL])
bool_ quest_nazgul_gen_hook(char *fmt)
diff --git a/src/q_nazgul.h b/src/q_nazgul.h
new file mode 100644
index 00000000..60720e3f
--- /dev/null
+++ b/src/q_nazgul.h
@@ -0,0 +1,13 @@
+#pragma once
+
+#include "angband.h"
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+
+bool_ quest_nazgul_init_hook(int q_idx);
+
+#ifdef __cplusplus
+} // extern "C"
+#endif
diff --git a/src/tables.c b/src/tables.c
index 75457f61..e08bfcb2 100644
--- a/src/tables.c
+++ b/src/tables.c
@@ -28,6 +28,7 @@
#include "q_spider.h"
#include "q_wolves.h"
#include "q_shroom.h"
+#include "q_nazgul.h"