summaryrefslogtreecommitdiff
path: root/vendor/bandit/specs/describe.spec.cpp
diff options
context:
space:
mode:
authorBardur Arantsson <bardur@scientician.net>2015-08-01 16:35:25 +0200
committerBardur Arantsson <bardur@scientician.net>2015-09-14 05:58:27 +0200
commit7b9f4e4e8169ca2fad3a1c7ca03f07ecfc46678e (patch)
tree0cef1ac0dc228b621afc90bc94e4e0dddcb90c82 /vendor/bandit/specs/describe.spec.cpp
parentc6196b25d119a10e79deedef26a73e0d5a021b0e (diff)
Bandit 2.0.0
Diffstat (limited to 'vendor/bandit/specs/describe.spec.cpp')
-rw-r--r--vendor/bandit/specs/describe.spec.cpp15
1 files changed, 12 insertions, 3 deletions
diff --git a/vendor/bandit/specs/describe.spec.cpp b/vendor/bandit/specs/describe.spec.cpp
index 7578fcac..d4600a28 100644
--- a/vendor/bandit/specs/describe.spec.cpp
+++ b/vendor/bandit/specs/describe.spec.cpp
@@ -3,7 +3,7 @@
using namespace bandit::fakes;
namespace bd = bandit::detail;
-go_bandit([](){
+SPEC_BEGIN(describe)
describe("describe:", [](){
bandit::detail::voidfunc_t describe_fn;
@@ -87,7 +87,7 @@ go_bandit([](){
describe("skip", [&](){
bool context_is_hard_skip;
- auto describe_fn =
+ describe_fn =
[&](){ context_is_hard_skip = context_stack->back()->hard_skip(); };
before_each([&](){
@@ -102,7 +102,16 @@ go_bandit([](){
});
});
+
+ describe("xdescribe", [&](){
+
+ it("pushes a context marked as skipped on the stack", [&](){
+ xdescribe("context name", describe_fn, *reporter, *context_stack);
+ AssertThat(context_is_hard_skip, IsTrue());
+ });
+
+ });
});
});
-});
+SPEC_END