summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/CMakeLists.txt2
-rw-r--r--src/plots.c1
-rw-r--r--src/plots.h1
-rw-r--r--src/q_wight.c4
-rw-r--r--src/q_wight.h13
-rw-r--r--src/tables.c1
6 files changed, 18 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2ffa3748..83e75b6b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -13,7 +13,7 @@ SET(SRCS
q_god.c q_library.c q_fireprof.c q_bounty.c q_thrain.c
q_narsil.c q_evil.c q_betwen.c q_haunted.c q_invas.c
q_nirna.c q_eol.c q_god.c q_dragons.c q_poison.c
- q_spider.c q_wolves.c q_shroom.c q_nazgul.c
+ q_spider.c q_wolves.c q_shroom.c q_nazgul.c q_wight.c
object1.c object2.c randart.c squeltch.cc traps.c
monster1.c monster2.c monster3.c
xtra1.c xtra2.c skills.c powers.c gods.c
diff --git a/src/plots.c b/src/plots.c
index 75370362..e0ad0e3e 100644
--- a/src/plots.c
+++ b/src/plots.c
@@ -373,4 +373,3 @@ bool_ quest_null_hook(int q)
#include "q_thief.c"
#include "q_hobbit.c"
#include "q_troll.c"
-#include "q_wight.c"
diff --git a/src/plots.h b/src/plots.h
index 1320e295..259bfaf3 100644
--- a/src/plots.h
+++ b/src/plots.h
@@ -21,4 +21,3 @@ extern bool_ quest_ultra_evil_init_hook(int q_idx);
extern bool_ quest_thieves_init_hook(int q_idx);
extern bool_ quest_hobbit_init_hook(int q_idx);
extern bool_ quest_troll_init_hook(int q_idx);
-extern bool_ quest_wight_init_hook(int q_idx);
diff --git a/src/q_wight.c b/src/q_wight.c
index 3f6b2c34..4be72fc2 100644
--- a/src/q_wight.c
+++ b/src/q_wight.c
@@ -1,4 +1,6 @@
-#undef cquest
+#include "q_wight.h"
+#include "quark.h"
+
#define cquest (quest[QUEST_WIGHT])
bool_ quest_wight_gen_hook(char *fmt)
diff --git a/src/q_wight.h b/src/q_wight.h
new file mode 100644
index 00000000..31b58882
--- /dev/null
+++ b/src/q_wight.h
@@ -0,0 +1,13 @@
+#pragma once
+
+#include "angband.h"
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+
+bool_ quest_wight_init_hook(int q_idx);
+
+#ifdef __cplusplus
+} // extern "C"
+#endif
diff --git a/src/tables.c b/src/tables.c
index e08bfcb2..756a3216 100644
--- a/src/tables.c
+++ b/src/tables.c
@@ -29,6 +29,7 @@
#include "q_wolves.h"
#include "q_shroom.h"
#include "q_nazgul.h"
+#include "q_wight.h"