summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt2
-rw-r--r--DEBUG.txt8
2 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 547e50d1..05c7bcff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,7 +10,7 @@ IF(CMAKE_COMPILER_IS_GNUCC)
# Let's set sensible options.
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pipe -Wall -Wno-unused-value")
SET(CMAKE_C_FLAGS_RELEASE "-O2")
- SET(CMAKE_C_FLAGS_DEBUG "-O1 -g")
+ SET(CMAKE_C_FLAGS_DEBUG "-O0 -g")
ENDIF()
# Add definitions.
diff --git a/DEBUG.txt b/DEBUG.txt
new file mode 100644
index 00000000..f7146c28
--- /dev/null
+++ b/DEBUG.txt
@@ -0,0 +1,8 @@
+Debugging
+=========
+
+To turn on Debug mode when compiling run cmake with the
+
+ -DCMAKE_BUILD_TYPE=Debug
+
+parameter.