summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt11
-rw-r--r--README.md2
2 files changed, 0 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6b804357..43cea2c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,17 +44,6 @@ ENDIF()
SET(LIBS ${LIBS} m)
#
-# JSON support
-#
-PKG_CHECK_MODULES(JANSSON REQUIRED jansson)
-IF(JANSSON_FOUND)
- ADD_DEFINITIONS(${JANSSON_CFLAGS})
- INCLUDE_DIRECTORIES(${JANSSON_INCLUDE_DIRS})
- LINK_DIRECTORIES(${JANSSON_LIBRARY_DIRS})
- SET(LIBS ${LIBS} ${JANSSON_LIBRARIES})
-ENDIF()
-
-#
# BOOST
#
FIND_PACKAGE(Boost 1.54.0 REQUIRED COMPONENTS system filesystem)
diff --git a/README.md b/README.md
index b61fd0b1..9ab5b368 100644
--- a/README.md
+++ b/README.md
@@ -11,7 +11,6 @@ See below for specific distribution-specific hints, if needed.
You will need to have the following libraries installed on your system
somewhere where CMake can find them:
-- [jansson](http://www.digip.org/jansson/)
- [Boost](https://www.boost.org/)
Version requirements may vary somewhat, but usually you should be
@@ -59,7 +58,6 @@ To compile on an Ubuntu install, you'll need at least the
- `cmake`
- `build-essential`
-- `libjansson-dev`
- `libboost-all-dev`
packages.