summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/CMakeLists.txt1
-rw-r--r--src/init2.cc21
-rw-r--r--src/main.c1
-rw-r--r--src/script.cc30
-rw-r--r--src/script.h12
5 files changed, 18 insertions, 47 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 942946fc..9919485d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -82,7 +82,6 @@ SET(SRCS_COMMON
quest.cc
randart.cc
range.cc
- script.cc
skills.cc
spell_type.cc
spells1.cc
diff --git a/src/init2.cc b/src/init2.cc
index 338ebf10..f56045b9 100644
--- a/src/init2.cc
+++ b/src/init2.cc
@@ -29,13 +29,16 @@
#include "player_class.hpp"
#include "player_race.hpp"
#include "player_race_mod.hpp"
+#include "q_library.hpp"
#include "quark.hpp"
#include "randart.hpp"
#include "randart_part_type.hpp"
-#include "script.h"
#include "set_type.hpp"
#include "skill_type.hpp"
#include "spells3.hpp"
+#include "spells4.hpp"
+#include "spells5.hpp"
+#include "spells6.hpp"
#include "squeltch.hpp"
#include "store_action_type.hpp"
#include "store_info_type.hpp"
@@ -1365,8 +1368,20 @@ void init_angband(void)
if (init_misc()) quit("Cannot initialise misc. values");
/* Initialise some other arrays */
- note("[Initialising scripting... (script)]");
- init_lua_init();
+ {
+ note("[Initialising scripting... (script)]");
+
+ /* Initialize schooled spells */
+ schools_init();
+ school_spells_init();
+ init_school_books();
+
+ /* Post-spell creation initialization */
+ initialize_bookable_spells();
+
+ /* Finish up the corruptions */
+ init_corruptions();
+ }
/* Initialise skills info */
note("[Initialising arrays... (skills)]");
diff --git a/src/main.c b/src/main.c
index 15b2966e..9845c21f 100644
--- a/src/main.c
+++ b/src/main.c
@@ -13,7 +13,6 @@
#include "files.h"
#include "init2.h"
#include "modules.h"
-#include "script.h"
#include "util.h"
#include "variable.h"
diff --git a/src/script.cc b/src/script.cc
deleted file mode 100644
index 84f7c3e4..00000000
--- a/src/script.cc
+++ /dev/null
@@ -1,30 +0,0 @@
-/*
- * Copyright (c) 2001 Dark God
- *
- * This software may be copied and distributed for educational, research, and
- * not for profit purposes provided that this copyright and statement are
- * included in all such copies.
- */
-
-#include "script.h"
-
-#include "init2.hpp"
-#include "q_library.hpp"
-#include "spells4.hpp"
-#include "spells5.hpp"
-#include "spells6.hpp"
-
-
-void init_lua_init()
-{
- /* Initialize schooled spells */
- schools_init();
- school_spells_init();
- init_school_books();
-
- /* Post-spell creation initialization */
- initialize_bookable_spells();
-
- /* Finish up the corruptions */
- init_corruptions();
-}
diff --git a/src/script.h b/src/script.h
deleted file mode 100644
index 3d1a0840..00000000
--- a/src/script.h
+++ /dev/null
@@ -1,12 +0,0 @@
-#pragma once
-
-// C linkage required for these functions since main-* code uses them.
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-extern void init_lua_init(void);
-
-#ifdef __cplusplus
-} // extern "C"
-#endif