summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 17 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index c31c20b0..2e01676a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -37,11 +37,21 @@ PKG_STATLIB= $(TMPTOP)$(PREFIX)/lib/$(package)
DPKG_ARCH := dpkg-architecture
export DEB_HOST_MULTIARCH := $(shell $(DPKG_ARCH) $(ha) -qDEB_HOST_MULTIARCH)
+DEB_HOST_ARCH := $(shell $(DPKG_ARCH) -qDEB_HOST_ARCH)
+CONFIGURE_ARGS :=
+ifneq (,$(filter amd64 arm64 armel armhf i386 powerpc ppc64 ppc64el x32 sparc sparc64,$(DEB_HOST_ARCH)))
+ # Upstream passes these unconditionally, but they're only available on
+ # certain architectures.
+ CONFIGURE_ARGS += \
+ -DCMAKE_C_FLAGS_DEBUG="${SANITIZER_FLAGS}" \
+ -DCMAKE_CXX_FLAGS_DEBUG="${SANITIZER_FLAGS}"
+endif
+
%:
dh $@
override_dh_auto_configure:
- dh_auto_configure -- -DSYSTEM_INSTALL:BOOL=true
+ dh_auto_configure -- -DSYSTEM_INSTALL:BOOL=true $(CONFIGURE_ARGS)
override_dh_auto_build:
bash -n debian/tome.postinst
@@ -70,9 +80,9 @@ override_dh_install:
override_dh_fixperms:
dh_fixperms
chgrp -R games $(TMPTOP)/etc/$(package)/* $(PKG_STATLIB)/* $(PKG_LIBDIR) \
- $(TMPTOP)/usr/games/tome
+ $(TMPTOP)/var/games/tome
chmod g+ws $(PKG_LIBDIR)/data/
- chmod g+s $(TMPTOP)/usr/games/tome
+ chmod g+s $(TMPTOP)/var/games/tome
override_dh_clean:
dh_clean
@@ -81,6 +91,10 @@ override_dh_clean:
touch ./lib/info/delete.me
touch ./lib/save/delete.me
touch ./lib/user/delete.me
+ test ! -e ${SRCTOP}/CMakeCache.txt || rm -f ${SRCTOP}/CMakeCache.txt
+ test ! -e ${SRCTOP}/Ccmake_install.cmake || rm -f ${SRCTOP}/cmake_install.cmake
+ test ! -e ${SRCTOP}/mAKEFILE || rm -f ${SRCTOP}/mAKEFILE
+ test ! -d ${SRCTOP}/CMakeFiles || rm -f ${SRCTOP}/CMakeFiles/
#Local variables:
#mode: makefile